Find the answer to your Linux question:
Results 1 to 2 of 2
Hi, everyone. I use Fedora 10 (64-bit) myself. And I have installed samba-3.2.11 cups-1:1.3.10-5 hplip-2.8.12-6 ghostscript-8.63-6 and I have copied the files: ps5ui.dll, pscript5.dll, pscript.hlp, pscript.ntf. And installed cups-windows-6.0-1.i386.rpm from ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2009
    Posts
    3

    [SOLVED] CUPS+Samba to a probably non-postscript printer


    Hi, everyone.

    I use Fedora 10 (64-bit) myself.
    And I have installed

    samba-3.2.11
    cups-1:1.3.10-5
    hplip-2.8.12-6
    ghostscript-8.63-6
    and I have copied the files: ps5ui.dll, pscript5.dll, pscript.hlp, pscript.ntf.
    And installed cups-windows-6.0-1.i386.rpm from the cups website
    (I am not sure whether it is right to use the i386 version)

    I want to share my printer to a Windows XP (32-bit) box.And my printer is the HP PSC 2210 all-in-one printer.I am not sure if it is a postscript printer , but I guess it's not.

    The driver of my printer was set up automatically by Fedora,and the printing works fine in the Fedora box.
    But when I want to print some thing from the client,it came out a full page of scripts like:

    %!PS-Adobe-3.0
    %cupsJobTicket: job-hold-until=no-hold
    %cupsJobTicket: job-sheets=n
    %%Title: <AE4CA474A5D1A8BD2DB25CA5FAB07BB07B>
    %%Creator: PScripts5.dll Version 5.2
    .........
    I guess it's postScript scripts.

    But the printer works well in Fedora,
    so I think the postscript interpreter exists.
    How come it goes wrong through SAMBA?

    Where should I modify my settings, or what document should I read?
    Thanks alot.


    The actual result of the printing goes like this :
    %!PS-Adobe-3.0
    %%Title: <A5BCA952A657202D20B04FA8C6A5BB>
    %%Creator: PScript5.dll Version 5.2
    %%CreationDate: 8/9/2009 1:59:23
    %%BoundingBox: (atend)
    %%Pages: (atend)
    %%Orientation: Portrait
    %%PageOrder: Ascend
    %%DocumentNeededResources: (atend)
    %%DocumentSuppliedResources: (atend)
    %%DocumentData: Clean7Bit
    %%TargetDevice: (PSC 2200 Series) (3010.000) 550
    %%LanguageLevel: 3
    %%EndComments

    %%BeginDefaults
    %%PageBoundingBox: 18 36 594 783
    %%ViewingOrientation: 1 0 0 1
    %%EndDefaults


    %%BeginProlog
    %%BeginResource: file Pscript_WinNT_ErrorHandler 5.0 0
    /currentpacking where{pop/oldpack currentpacking def/setpacking where{pop false
    setpacking}if}if/$brkpage 64 dict def $brkpage begin/prnt{dup type/stringtype
    ne{=string cvs}if dup length 6 mul/tx exch def/ty 10 def currentpoint/toy exch
    def/tox exch def 1 setgray newpath tox toy 2 sub moveto 0 ty rlineto tx 0
    rlineto 0 ty neg rlineto closepath fill tox toy moveto 0 setgray show}bind def
    /nl{currentpoint exch pop lmargin exch moveto 0 -10 rmoveto}def/=={/cp 0 def
    typeprint nl}def/typeprint{dup type exec}readonly def/lmargin 72 def/rmargin 72
    def/tprint{dup length cp add rmargin gt{nl/cp 0 def}if dup length cp add/cp
    Does the message "Pscript_WinNT_ErrorHandler" imply that I'm using a wrong driver?

  2. #2
    Just Joined!
    Join Date
    Aug 2009
    Posts
    3
    I solved it by myself ...........

    It is caused by a default setting in the file /etc/samba/smb.conf

    # Cups Options let you pass the cups libs custom options, setting it to raw
    # for example will let you use drivers on your Windows clients

    cups options = raw
    This line exists by default in the config file.But after I comment out this line, the problem is solved.
    that is, change this line to
    ; cups options = raw
    Then samba will use the default value for this entry:
    cups options = ""
    , as shown in the manpage "man smb.conf"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •