Find the answer to your Linux question:
Results 1 to 5 of 5
I am having trouble mounting with cifs, but mounting the exact same command with smbfs works fine. The share is on another samba server and is set to full public ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie humbletech99's Avatar
    Join Date
    Nov 2005
    Posts
    225

    mount -t cifs permission denied by mount -t smbfs works fine


    I am having trouble mounting with cifs, but mounting the exact same command with smbfs works fine. The share is on another samba server and is set to full public guest access.

    Code:
    # mount -t cifs //servername/sharename /mnt/temp -o password=""
    mount error 13 = Permission denied
    Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
     
    ==> /var/log/messages <==
    Sep  1 16:43:25 clientname Status code returned 0xc000006d NT_STATUS_LOGON_FAILURE
    Sep  1 16:43:25 clientname CIFS VFS: Send error in SessSetup = -13
    Sep  1 16:43:25 clientname CIFS VFS: cifs_mount failed w/return code = -13
    
    # mount -t smbfs //servername/sharename /mnt/temp -o password=""
    Anonymous login successful
    I can then read and write files in /mnt/temp over smbfs but I cannot even mount it using cifs, but there are other cifs filesystems from other samba servers that mounted fine on this machine. I have the same problem mounting this one share from all linux boxen... but those same linux boxen can mount cifs shares from other machines just fine.

    Any ideas why?
    The Human Equation:

    value(geeks) > value(mundanes)

  2. #2
    Just Joined!
    Join Date
    Jul 2009
    Posts
    58
    Try adding --verbose to the cifs mount statement to see if it tells you what is failing.

  3. #3
    Linux Newbie humbletech99's Avatar
    Join Date
    Nov 2005
    Posts
    225
    It only tells me the mount.cifs kernel mount options but no more information other than the mount error 13 = Permission denied.
    The Human Equation:

    value(geeks) > value(mundanes)

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    Jan 2008
    Location
    Canada
    Posts
    109
    Hi humbletech99
    Not sure it is still valid but does offer some help. Try URL Vijay Kumar's Blog: Cifs "mount error 13 = Permission denied"
    Cheers...
    Robert

  6. #5
    Linux Newbie humbletech99's Avatar
    Join Date
    Nov 2005
    Posts
    225
    Thanks for that. I tried the domain trick. but it still didn't work, I am using 2.6.18 so it is highly likely that I would be affected by this bug... but appending domain=xx does work, and I have tried variations on my domain name, the netbios version, the dns version etc and still no joy!
    The Human Equation:

    value(geeks) > value(mundanes)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •