I have the above listed versions of software, a basic goDaddy ssl certificate and I have 2 ip addresses on my vps account. I have two domains, jayellisweddings dot com and jayelliscorp dot com they both are redirected to different document roots /var/www/jayelliscorp dot com
and /var/www/jayellisweddings dot com respectively.

I am trying to install my SSl certificate on jayelliscorp dot com

I made a virtualhost for port :443 and one for :80, but I can't get the config right after over 2 dozen tries, I have read many articles, but the directions listed on apache help tutorials don't work for my situation. If I have ssl enabled yes instead of default in webmin, then only ssl pages work and http pages give me a bad request error 400. If I have ssl set to default in webmin then http works, but https: gives me a ssl certificated to long error.

I don't know what is wrong, but here is the relevant portion of my config file.


#
# Use name-based virtual hosting.
#
#NameVirtualHost *:80
#
# NOTE: NameVirtualHost cannot be used without a port specifier
# (e.g. :80) if mod_ssl is being used, due to the nature of the
# SSL protocol.
#

#
# VirtualHost example:
# Almost any Apache directive may go into a VirtualHost container.
# The first VirtualHost section is used for requests without a known
# server name.
#

NameVirtualHost *:443
NameVirtualHost *:80

<VirtualHost 69.163.34.164:*>
DocumentRoot "/var/www/jayellisweddings dot com"
<Directory "/var/www/jayellisweddings dot com">
allow from all
Options +Indexes
</Directory>
SSLEngine off
</VirtualHost>
<VirtualHost 69.163.34.163:443>
DocumentRoot /var/www/jayelliscorp dot com
<Directory "/var/www/jayelliscorp dot com">
allow from all
Options +Indexes
</Directory>
SSLEngine on
SSLCertificateFile /etc/pki/tls/certs/jayelliscorp dot com.crt
SSLCertificateKeyFile /etc/pki/tls/private/jayelliscorp.key
</VirtualHost>
<VirtualHost 69.163.34.163:80>
DocumentRoot /var/www/jayelliscorp dot com
<Directory "/var/www/jayelliscorp dot com">
allow from all
Options +Indexes
</Directory>
</VirtualHost>

EDIT: I figured it out after 7 hours of trial and error

<VirtualHost 69.163.34.163:443>
ServerName domain
DocumentRoot /var/www/domain
SSLEngine on
SSLCertificateFile /etc/pki/tls/certs/file
SSLCertificateKeyFile /etc/pki/tls/private/file
</VirtualHost>

<VirtualHost 69.163.34.163:80>
ServerName domain
DocumentRoot /var/www/domain
</VirtualHost>

I made it listen on the ports. It was using name based vhosts, and I was trying not to. Apache is pretty touchy, but I hope this helps someone else who is hosting multiple static ip addresses on 1 server with an ssl certificate.