Find the answer to your Linux question:
Results 1 to 3 of 3
I am trying to install VMware Server on my Debian "Lenny" machine and I'm having a couple problems. When I run `sudo ./vmware-install.pl`I am prompted with the following: Code: Using ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! KPolulak's Avatar
    Join Date
    Feb 2009
    Location
    New Jersey, USA
    Posts
    42

    Unhappy Trouble with VMware Server Installation


    I am trying to install VMware Server on my Debian "Lenny" machine and I'm having a couple problems.

    When I run `sudo ./vmware-install.pl`I am prompted with the following:

    Code:
    Using compiler "/usr/bin/gcc". Use environment variable CC to override.
    
    Your kernel was built with "gcc" version "4.1.3", while you are trying to use
    "/usr/bin/gcc" version "4.3.2". This configuration is not recommended and
    VMware Server may crash if you'll continue. Please try to use exactly same
    compiler as one used for building your kernel. Do you want to go with compiler
    "/usr/bin/gcc" version "4.3.2" anyway? [no]
    First time through, I chose "No" and the script aborted. I then ran `gcc -v` to verify that this message was correct and indeed it was. Here's the output:

    Code:
    Using built-in specs.
    Target: i486-linux-gnu
    Configured with: ../src/configure -v --with-pkgversion='Debian 4.3.2-1.1' --with-bugurl=file:///usr/share/doc/gcc-4.3/README.Bugs --enable-languages=c,c++,fortran,objc,obj-c++ --prefix=/usr --enable-shared --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --enable-nls --with-gxx-include-dir=/usr/include/c++/4.3 --program-suffix=-4.3 --enable-clocale=gnu --enable-libstdcxx-debug --enable-objc-gc --enable-mpfr --enable-targets=all --enable-cld --enable-checking=release --build=i486-linux-gnu --host=i486-linux-gnu --target=i486-linux-gnu
    Thread model: posix
    gcc version 4.3.2 (Debian 4.3.2-1.1)
    I then decided to take my chances and choose "Yes" at the above prompt. Sure enough, the installer did crash and here is what it complained about:

    Code:
    What is the location of the directory of C header files that match your running
    kernel? [/lib/modules/2.6.26-2-686/build/include]
    
    Extracting the sources of the vmmon module.
    
    Building the vmmon module.
    
    Using 2.6.x kernel build system.
    make: Entering directory `/tmp/vmware-config0/vmmon-only'
    make -C /lib/modules/2.6.26-2-686/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
    make[1]: Entering directory `/usr/src/linux-headers-2.6.26-2-686'
    /tmp/vmware-config0/vmmon-only/Makefile:106: *** Inappropriate build environment: you wanted to use gcc version 4.3.2 while kernel attempts to use gcc version 4.1.3.
    /tmp/vmware-config0/vmmon-only/Makefile:108: *** For proper build you'll have to replace  gcc-4.1 with symbolic link to /usr/bin/gcc.  Stop.
    make[1]: *** [_module_/tmp/vmware-config0/vmmon-only] Error 2
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.26-2-686'
    make: *** [vmmon.ko] Error 2
    make: Leaving directory `/tmp/vmware-config0/vmmon-only'
    Unable to build the vmmon module.
    
    For more information on how to troubleshoot module-related problems, please
    visit our Web site at "http://www.vmware.com/go/unsup-linux-products" and
    "http://www.vmware.com/go/unsup-linux-tools".
    
    Execution aborted.
    What should I do? It mentions in the first code snippet that I can override the default path of "usr/bin/gcc" by defining the environment variable $CC. I checked and this variable is currently undefined.

  2. #2

  3. #3
    Just Joined! KPolulak's Avatar
    Join Date
    Feb 2009
    Location
    New Jersey, USA
    Posts
    42
    Wow, problem solved. VMware Server 2 now completely installed.

    Ugh, I searched Google up and down but could not find anything. Mostly because I wasn't search of what keywords to use.

    Anyway, thank you so much. I wanted to get a second person's opinion first before I did anything since the messages I was getting referred to expert-level tasks like compiling the kernel.

    Thank you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •