Find the answer to your Linux question:
Results 1 to 5 of 5
OK I am trying to setup MySQL through rpms and when i try to install to install the first package i get this error: Code: warning: //root/MySQL-server-4.0.21-0.i386.rpm: V3 DSA signature: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Location
    VA
    Posts
    5

    MySQL RPM's not installing


    OK I am trying to setup MySQL through rpms and when i try to install to install the first package i get this error:

    Code:
    warning: //root/MySQL-server-4.0.21-0.i386.rpm: V3 DSA signature: NOKEY, key ID 5072e1f5
    error: Failed dependencies:
    	fileutils is needed by MySQL-server-4.0.21-0
    	sh-utils is needed by MySQL-server-4.0.21-0
    	/bin/sh is needed by MySQL-server-4.0.21-0
    	/usr/bin/perl is needed by MySQL-server-4.0.21-0
    I thought that some of the stuff it was requestiong was odd because I should already have at least fileutils. I am running Slack 10. Any ideas?

  2. #2
    Linux Newbie
    Join Date
    Oct 2004
    Location
    Manchester, England
    Posts
    165
    maybe you have the wrong version from what it needs ?
    shouldn't your package manager select the dependencies for you anyway ?

  3. #3
    Just Joined!
    Join Date
    Oct 2004
    Location
    VA
    Posts
    5
    well i went back in to kpackage to give it another try and i realized that i forgot to uncheck the upgrade and replace packages option but i still left check dependencies option checked. this is what resulted:
    Code:
    	/bin/sh is needed by MySQL-shared-4.0.21-0
    	ld-linux.so.2 is needed by MySQL-shared-4.0.21-0
    	libc.so.6 is needed by MySQL-shared-4.0.21-0
    	libc.so.6(GLIBC_2.0) is needed by MySQL-shared-4.0.21-0
    	libc.so.6(GLIBC_2.1) is needed by MySQL-shared-4.0.21-0
    	libc.so.6(GLIBC_2.1.2) is needed by MySQL-shared-4.0.21-0
    	libc.so.6(GLIBC_2.1.3) is needed by MySQL-shared-4.0.21-0
    	libc.so.6(GLIBC_2.2) is needed by MySQL-shared-4.0.21-0
    	libcrypt.so.1 is needed by MySQL-shared-4.0.21-0
    	libm.so.6 is needed by MySQL-shared-4.0.21-0
    	libnsl.so.1 is needed by MySQL-shared-4.0.21-0
    	libnss_dns.so.2 is needed by MySQL-shared-4.0.21-0
    	libnss_files.so.2 is needed by MySQL-shared-4.0.21-0
    	libpthread.so.0 is needed by MySQL-shared-4.0.21-0
    	libpthread.so.0(GLIBC_2.0) is needed by MySQL-shared-4.0.21-0
    	libpthread.so.0(GLIBC_2.2) is needed by MySQL-shared-4.0.21-0
    	libresolv.so.2 is needed by MySQL-shared-4.0.21-0
    	libz.so.1 is needed by MySQL-shared-4.0.21-0
    i guess i need to download something called glib, could someone point me in the right direction. i tried google but that just confused me even more.

  4. #4
    Just Joined!
    Join Date
    Sep 2004
    Location
    vacaville, ca
    Posts
    34
    i think its

    rpm --nodep mysql.rpm

    something like that just will not check any deps for it... sometimes just have to foce install stuff and you know what deps it has

  5. #5
    Linux Enthusiast
    Join Date
    Jun 2002
    Location
    San Antonio
    Posts
    621
    Slackware is not an RPM based distribution. This means that you should probably download, compile, and install the source. Either that, or see if they have tgz's of the package (which I don't think they do). If you use the --nodeps option that jubjub mentioned, you should be able to install the package, however it may not have all the dependencies installed yet.

    Best,

    Samuel
    I respectfully decline the invitation to join your delusion.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •