Find the answer to your Linux question:
Results 1 to 7 of 7
Okay - I apologise if this is someone already has an answer for this someplace in here. Kind of under the gun - I want to make sure that I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! bartockbat's Avatar
    Join Date
    Mar 2007
    Posts
    3

    Apache 2.2.8 Ubuntu not accepting connections from outside LAN


    Okay - I apologise if this is someone already has an answer for this someplace in here. Kind of under the gun - I want to make sure that I am not on a 'Wild Goose Chase'

    I have an Apache 2.2.8 server running on an Ubuntu (Debian 4.3.2-1 kernel 2.6.28.1) . It only will accept connections from the localhost. I run Firefox in an X window on the server, I can get to it just fine. However, I attempt to connect from an external IP, and I cannot.

    I run a sniffer on my local machine here, and it seems to want to connect (if anyone wants me to post the trace I will) and when I run a sniffer on the remote machine (the one where the web server is), it is getting an http request to the machine.

    I checked the iptables - nothing blocked.

    I have verbose (debug logging) turned on. I don't see anything.

    I am thinking one of two things:

    1. it (apache) is configured to not accept external connections - and I do not know how to check this.
    2. the hosting provider has it blocked somehow that I cannot see.

    To add mystery I have Tomcat running on the same server (tcp port 8080) and I can reach it just fine.

    Any helpful words of wisdom from anyone?

    Thanks - it would be much appreciated!

    Glen

  2. #2
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,310
    This is probably a probelm with the configuration of the site in Apache. This is probably a virtual host.

    Have a look in /etc/apache2/sites-available and there should be a file with a similar name to your site. You will be be looking for Allow / Deny. It sounds like it is denying all but localhost
    What do we want?
    Time machines!

    When do we want 'em?
    Doesn't really matter does it!?


    Conkybots: Interactive plugins for your Conkys!

  3. #3
    Just Joined! bartockbat's Avatar
    Join Date
    Mar 2007
    Posts
    3

    Unhappy config file

    NameVirtualHost *
    <VirtualHost *>
    ServerAdmin webmaster@localhost

    DocumentRoot /var/www/
    <Directory />
    Options FollowSymLinks
    AllowOverride None
    </Directory>
    <Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    Allow from all
    </Directory>

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
    AllowOverride None
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
    </Directory>

    ErrorLog /var/log/apache2/error.log

    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel debug

    CustomLog /var/log/apache2/access.log combined
    ServerSignature On

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
    Options Indexes MultiViews FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
    Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

    </VirtualHost>

    Hi - thank you for responding!

    Above is the contents of the only file in the sites-available directory. I don't see anything that would indicate any IP denial.
    Any other words of wisdom for me?

    Thanks

    Glen

  4. #4
    Linux Newbie
    Join Date
    Feb 2006
    Location
    KP22
    Posts
    106
    Your config looks just fine to me. Have you checked that the other applicable config files (from /etc/apache2) don't interfere with these settings?

    As far as I understood, the web server machine is receiving the packets. Does it reset the connection or just drop the packets?
    Have you checked every apache logfile?

    Perhaps, as an easy test, you could try to bind apache on a different port.

  5. #5
    Just Joined!
    Join Date
    Dec 2008
    Posts
    35
    How are the external connections coming through? Via external IP or website name?

  6. #6
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,310
    Looks OK to me too.

    Are there any clues in your error log?
    What do we want?
    Time machines!

    When do we want 'em?
    Doesn't really matter does it!?


    Conkybots: Interactive plugins for your Conkys!

  7. #7
    Banned
    Join Date
    Feb 2010
    Posts
    31

    Blocked http

    What does your "Listen" line in httpd.conf say?
    Are you listening on port 80?
    I think you want:
    <VirtualHost *:80>
    NOT
    <VirtualHost *>

    Last what does your "Bind" line look like? are you binding to all IPs on your machine?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •