Find the answer to your Linux question:
Results 1 to 5 of 5
I am not able to use outlook or any other email client on my computer(to access gmail account) I am also not able to forward port to my computer for ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2010
    Posts
    3

    [SOLVED] * ipexside not able to use outlook/thunderbird behind squid p


    I am not able to use outlook or any other email client on my computer(to access gmail account)
    I am also not able to forward port to my computer for a bit torrent client

    I can access the internet using proxy settings

    I have just installed CentOS 5 as a server with 2 NIC's for my home network.

    My set up is something like this

    adsl wireless router(static ip from ISP) - (192.168.0.1/24) Cent os server (10.1.1.1/ - switch/hub - clients(windows XP/Vista,Linux)

    the linux server acts as a Web Server,DHCP and Squid proxy server



    Will installing an email server resolve my problem?

    or is there anything else I should do?

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,846
    What you have is no IP route through your server to the internet. Web requests are being handled by your proxy server (squid) which can go off to the internet for information.

    If you need to access the internet directly, you'll need to turn on some kind of NAT firewalling alongside your proxy. If you want to investigate this further, then google IPTables. It's a vast subject and if you get it wrong can give you security problems, but simply turning it on for NAT is pretty straightforward.
    Linux user #126863 - see http://linuxcounter.net/

  3. #3
    Just Joined!
    Join Date
    Jan 2010
    Posts
    3
    I have enabled ip forwarding and tried it with iptables turned off

    it is still not working

  4. #4
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,846
    You need NAT turning on. I believe you need to add a 'MASQUERADE' somewhere to your IPTables configuration line, but the nuts-and-bolts of IPTables are unknown to me (I never have to use it). There is some help here at howtoforge, and you may find this at revsys to be a useful alternative.

    I'm surprised you did IP forwarding with iptables turned off, I thought iptables did this for you.
    Linux user #126863 - see http://linuxcounter.net/

  5. #5
    Just Joined!
    Join Date
    Jan 2010
    Posts
    3
    Quote Originally Posted by Roxoff View Post
    You need NAT turning on. I believe you need to add a 'MASQUERADE' somewhere to your IPTables configuration line, but the nuts-and-bolts of IPTables are unknown to me (I never have to use it).
    The above worked.

    Thanx Roxoff

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •