Hey,

I am currently working on hosting my own website on my laptop which is running on Ubuntu 9.10 and I have only just tried out XAMPP and I done so by following the steps mentioned at this URL apache friends - xampp for linux and I also followed these steps to creating virtual hosting with my own domain from here: How To Create XAMPP Virtual Host For Domain !! Am!NeS0Fts blog

...but the problem is, I want anyone on the internet to view the website I have made but when somebody tries, they always see a webpage saying either website or server not found and I don't know what I have done wrong.

Here is my /etc/hosts file:

Code:
root@computer:~# cat /etc/hosts
127.0.0.1   localhost
127.0.1.1   hbkai           server
127.0.2.1   www.hb-kai.net


# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
This is the extra-httpd.conf file:

Code:
root@computer:/home/me/SFN# cat extra-httpd.conf
<VirtualHost 127.0.2.1>
ServerName hbkai
DocumentRoot /home/me/my-website.net

<Directory /home/me/my-website.net>
AllowOverride All
Options All
</Directory>
</VirtualHost>
I did see the thread below this one asking about Apache server help on Debian but I read it and since I'm using LAMPP and everything is in /opt and I'm on Ubuntu 9.10, I thought I'd ask in a seperate thread, however, I did check through that thread to see if was anything I could do that was suggested there but could not find anything.



I was just wondering if somebody could see if I have done something wrong somewhere? Another thing is, while I'm doing this do I need to setup a DNS server on my laptop?

Thanks in advanced.



Edit:- I was just taking a look through /opt/lampp to see if I could find anything to resolve this issue and found this file too:

Code:
me@computer:~$ cat /opt/lampp/htdocs/index.php
<?php
	if (!empty($_SERVER['HTTPS']) && ('on' == $_SERVER['HTTPS'])) {
		$uri = 'https://';
	} else {
		$uri = 'http://';
	}
	$uri .= $_SERVER['HTTP_HOST'];
	header('Location: '.$uri.'/xampp/');
	exit;
?>
Something is wrong with the XAMPP installation :-(