Find the answer to your Linux question:
Results 1 to 4 of 4
Hi everyone. I was doing a little project for work, we have a Linux box laying around and I thought I'd make it a file server since we could use ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2008
    Posts
    12

    File Sharing in a Windows Domain


    Hi everyone.

    I was doing a little project for work, we have a Linux box laying around and I thought I'd make it a file server since we could use another one. Now I know my way around Linux a bit but I've never configured Samba to be used in a Domain, just in a LAN and with local authorization.

    Now we have an Active Directory server running under Win Server 2008, and what I'm trying to do is to have like a Share folder under my Linux box, where certain groups can enter certain directories. I have 9.10 installed, not the server cause it wasn't ment to be a server, just a simple testing and monitoring machine, and I was trying to follow the guide posted on how to forge:

    howtoforge.com/ubuntu-9.04-samba-server-integrated-with-active-directory

    But I always get a DNS update fail error, I changed my hosts file to point to my domain server and it kinda worked: I could access it like a share folder, but it asked for an user and a password, I tried entering several users from the domain and it didn't worked.

    The guide says I need to have everything setup for the server, it asumes perharps that one is running Ubuntu server and perhaps I'm missing something. On a bright note I could authenticate myself with Kerberos and create a ticket successfully.

    Has anyone succeeded in doing this that perhaps can give me a hand?

    Thanks for your time.

  2. #2
    Linux Enthusiast scathefire's Avatar
    Join Date
    Jan 2010
    Location
    Western Kentucky
    Posts
    626
    let's see your smb.conf file
    linux user # 503963

  3. #3
    Just Joined!
    Join Date
    Oct 2008
    Posts
    12
    Here's what I have in my smb.conf

    Code:
    [global]
            workgroup = DOMAIN
            realm = DOMAIN.COM
            preferred master = no
            server string = Linux Share Server
            security = ADS
            encrypt passwords = yes
            log level = 3
            log file = /var/log/samba/%m
            max log size = 50
            winbind enum users = Yes
            winbind enum groups = No
            winbind use default domain = Yes
            winbind nested groups = Yes
            winbind separator = +
            idmap uid = 600 - 20000
            idmap gid = 600 - 20000
            template shell = /bin/bash
            guest account = nobody
    
    [Share] 
    	comment = Shared files
    	path = /opt/Share
            writeable = yes
            public = yes
            browseable = yes
            guest ok = yes
    I've changed my domain name to DOMAIN but I'm writing the domain we're using. Now some progress has been done. If I type wbinfo -u and wbinfo -g I can see our AD users and groups so I think that means that we I'm in the domain.

    Now I created a shared folder just to test it out but when a Windows machine is trying to access the linux machine, let's say \\12.12.12.12 I get a "No process at the end of the pipe" error, or something like that.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast scathefire's Avatar
    Join Date
    Jan 2010
    Location
    Western Kentucky
    Posts
    626
    Code:
    winbind separator = +
    That line caused me trouble in the past. Does the server show up in the network? Not necessarily any shares visible, but the server itself.
    linux user # 503963

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •