Find the answer to your Linux question:
Results 1 to 2 of 2
hey guys, So I recently converted my RAID 1 of 2 1TB hard drives to a RAID 5 of 4 1TB hard drives following this (sorry can't post links yet): ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2010
    Posts
    3

    Question [SOLVED] xfs and mdadm raid 5


    hey guys,
    So I recently converted my RAID 1 of 2 1TB hard drives to a RAID 5 of 4 1TB hard drives following this (sorry can't post links yet):
    Code:
    httx://scott.wallace.sh/2007/04/14/converting-raid1-to-raid5-with-no-data-loss/
    Everything appears to work, I've lost no data. It took several days all together to complete but now it appears to be up and running. I then did a xfs_growfs on the filesystem and it appears to have worked, but when I try to write to the filesystem, it says it's full. Any suggestions?

    --
    Travis

    Code:
    batman:/home/shared # mdadm --detail /dev/md0
    /dev/md0:
            Version : 0.90
      Creation Time : Wed Feb 10 18:55:08 2010
         Raid Level : raid5
         Array Size : 2930255808 (2794.51 GiB 3000.58 GB)
      Used Dev Size : 976751936 (931.50 GiB 1000.19 GB)
       Raid Devices : 4
      Total Devices : 4
    Preferred Minor : 0
        Persistence : Superblock is persistent
    
        Update Time : Sat Feb 13 13:53:28 2010
              State : clean
     Active Devices : 4
    Working Devices : 4
     Failed Devices : 0
      Spare Devices : 0
    
             Layout : left-symmetric
         Chunk Size : 64K
    
               UUID : 45d7aa33:92513c06:dc9e6d5c:da1c953a (local to host batman)
             Events : 0.656148
    
        Number   Major   Minor   RaidDevice State
           0       8       17        0      active sync   /dev/sdb1
           1       8        1        1      active sync   /dev/sda1
           2       8       49        2      active sync   /dev/sdd1
           3       8       33        3      active sync   /dev/sdc1
    Code:
    batman:/home/shared # df -h
    Filesystem            Size  Used Avail Use% Mounted on
    /dev/sde1              19G  4.2G   14G  24% /
    udev                  374M  124K  373M   1% /dev
    /dev/md0              2.8T  950G  1.9T  34% /home
    Code:
    batman:/home/shared # mkdir test
    mkdir: cannot create directory `test': No space left on device
    Code:
    batman:/home/shared # mount
    /dev/sde1 on / type reiserfs (rw,acl,user_xattr)
    /proc on /proc type proc (rw)
    sysfs on /sys type sysfs (rw)
    debugfs on /sys/kernel/debug type debugfs (rw)
    udev on /dev type tmpfs (rw)
    devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
    fusectl on /sys/fs/fuse/connections type fusectl (rw)
    securityfs on /sys/kernel/security type securityfs (rw)
    none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
    rpc_pipefs on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
    /proc on /var/lib/ntp/proc type proc (ro)
    /dev/md0 on /home type xfs (rw)
    Code:
    batman:/home/shared # uname -a
    Linux batman 2.6.27.7-9-default #1 SMP 2008-12-04 18:10:04 +0100 x86_64 x86_64 x86_64 GNU/Linux
    also, I'm running OpenSuSE 11.1

  2. #2
    Just Joined!
    Join Date
    Feb 2010
    Posts
    3
    Alright, it appears I solved the problem. The problem was not with the mdadm change, but in the xfs_growfs. I was still mounting the filesystem with inode32 and I needed to add the option "inode64" to the fstab to allow it to access more inodes (I think). Anyways, it's all good now.

    found info here:
    httx://xfs.org/index.php/XFS_FAQ#Q:_Why_do_I_receive_No_space_left_on_devic e_after_xfs_growfs.3F

    Code:
    batman:/home/shared # cat /etc/fstab 
    /dev/disk/by-id/ata-QUANTUM_FIREBALLlct15_20_613025550914-part2 swap                 swap       defaults              0 0
    /dev/disk/by-id/ata-QUANTUM_FIREBALLlct15_20_613025550914-part1 /                    reiserfs   acl,user_xattr        1 1
    proc                 /proc                proc       defaults              0 0
    sysfs                /sys                 sysfs      noauto                0 0
    debugfs              /sys/kernel/debug    debugfs    noauto                0 0
    usbfs                /proc/bus/usb        usbfs      noauto                0 0
    devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
    /dev/md0 /home                xfs        defaults,inode64              1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •