Find the answer to your Linux question:
Results 1 to 4 of 4
Hello, I am currently doing some training with linux and I am running into a problem. Here is what I am doing and did : 1. I installed Ubuntu server ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2008
    Location
    Angers, France
    Posts
    91

    [SOLVED] DCHP3 and DNS


    Hello,

    I am currently doing some training with linux and I am running into a problem.

    Here is what I am doing and did :

    1. I installed Ubuntu server on VMWare
    a. I installed DHCP3. I configured all the different files
    2. I installed Ubuntu 9.04 and put it on the same network using VMWare. All is OK and the host is getting an IP address from the DHCP Server. Good

    Now here is the problem :
    1. I am trying to install Asterisk to run some test.
    2. When I try to install it, nothing happens.
    3. I can ping my gateway from the server and I can ping the IPaddress of Google.com.
    4. I cannot ping Google or others

    I don't want to uninstall DHCP3. I tried to enter my DNS in different config files, changed the IP addresses so it would be on the same network than my ISP... but nothing.

    Do I need to uninstall DHCP3 or can I enter or change something somewhere in the file so the DNS will work ?

    I thought of installing bind9 but of course I can't download the files as I cannot access with the DNS ???

    What shall I do ? thanks a lot.

  2. #2
    Just Joined!
    Join Date
    Nov 2008
    Posts
    29
    you're saying your client gets an IP address. Cool. Did you set a gateway address as well, so that your client is forwarding traffic to the right place? Is the client's routing OK?
    Please show us your dhcpd.conf and the output of route on the client.

  3. #3
    Linux User
    Join Date
    Dec 2009
    Posts
    260
    Since you are able too ping Internet IPs the IP and gateway setting from the DHCP Server seems ok.
    However there should be a setting for the DNS-Server on the DHCP Server.
    The clients usually sets the DNS Server address when he gets the information by the DHCP Server...
    You may wanna take a look into the resolve.conf file in /etc/
    There you find the set DNS Server.

    You can use nslookup or host too test if the DNS Server is reachable and working correct.
    nslookup Google
    host Google <DNS-SERVER>

  4. #4
    Just Joined!
    Join Date
    Apr 2008
    Location
    Angers, France
    Posts
    91
    Thanks a lot. Did look at resolve.conf file. Did not know about this one. This handled it. Thanks a lot.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •