Find the answer to your Linux question:
Results 1 to 1 of 1
As FTP never seemed to work on Debian, I tried webmin with its filemanager. This was not a problem until today. A certain user with access to certain directory can ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2010
    Posts
    1

    [SOLVED] Webmin bad file descriptor on Filemanager


    As FTP never seemed to work on Debian, I tried webmin with its filemanager. This was not a problem until today. A certain user with access to certain directory can no longer edit, or write to files, it error out with bad file descriptor. Doing exactly the same as root does not give an issue for some reason. I check permissions, settings, but I cannot find anything wrong. Also creating a clone of the user and then trying also seems not to work.
    It seems to be related to that specific directory. I tried, with success, editing in another directory using another user.
    Webmin is at 1.500, the server runs Debian Lenny.

    === Edit ===

    We managed to crack it. It was a group issue. Webmin seemed to expect the group to be the same as the user. A simple chown -Rv foo:foo /dir/ect/ory/* seems to have fixed it, for now.
    Last edited by manti111; 02-27-2010 at 04:51 PM. Reason: Problem Solved

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •