Find the answer to your Linux question:
Results 1 to 4 of 4
Hi there, Do you know if this is possible with this version ? As I don't have access to begin-new-user-class command. Unknown variable "begin-new-user-class" on line 231 of configuration file. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Posts
    3

    NCftpd 2.7.1 > limiting bandwidth per user


    Hi there,

    Do you know if this is possible with this version ? As I don't have access to begin-new-user-class command.


    Unknown variable "begin-new-user-class" on line 231 of configuration file.
    Exiting.

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Freshmeat's project page for it says that you can use a built-in qos to limit down/up stream. I didn't see any docs there (or on the project's main site for that matter). Is this the method you have tried? Have you double-checked your config? It's possible that you have a typo somewhere near that definition...Also...have you seen other configs with this working? If so, copy them and work from there.

    Remember: Get it working. Then get it working right.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Just Joined!
    Join Date
    Oct 2004
    Posts
    3
    yup, I finally upgraded to latest version, first step I had to do to get it working.
    Now I have another problem, but nothing is documented with this FTP server

    Syntax error in password record's field #12 (0)
    Now i got this in ncftpd logs... Not sure anyone can help.
    I'm using my own user's password DB, activated quota.
    Field #12 is the "quota option", which is not documented on their website. tryied 0 and 1.. same problem.
    Used the ncftpd_edquota, and added manually, no changes either.
    Looks like this :
    ncftpd_passwd -f /usr/local/etc/ncftpd/userpw.db -a testuserass:555:99::/home/usertest::4000:2800:500:450:0:8:0 -5

    But this is working :
    ncftpd_passwd -f /usr/local/etc/ncftpd/userpw.db -a test2ass:555:99::/home/usertest::0:0:0:0:0:0:0 -5
    Basically, when no quota are activated.


    From the client I get :
    Command: USER test
    Response: 331 User test okay, need password.
    Command: PASS ****
    Response: 530 Login failed. Have the sysadmin check the misc log.
    Error: Disconnected from server
    Nothing exiting here either.

  4. #4
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Can't really help you there, as that is specific to the ftpd. Why not use vsftpd or something that is more widely-used and documented? Just a suggestion..
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •