Find the answer to your Linux question:
Results 1 to 2 of 2
Hello! I'm trying to synchronize a client with an ntpdate server. The ntp.conf file from the server has the following lines: # /etc/ntp.conf, configuration for ntpd; see ntp.conf(5) for help ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2010
    Posts
    6

    Synchronization with ntpdate


    Hello!
    I'm trying to synchronize a client with an ntpdate server.
    The ntp.conf file from the server has the following lines:

    # /etc/ntp.conf, configuration for ntpd; see ntp.conf(5) for help

    driftfile /var/lib/ntp/ntp.drift

    # Enable this if you want statistics to be logged.
    #statsdir /var/log/ntpstats/

    statistics loopstats peerstats clockstats
    filegen loopstats file loopstats type day enable
    filegen peerstats file peerstats type day enable
    filegen clockstats file clockstats type day enable

    # You do need to talk to an NTP server or two (or three).
    server pool.ntp.org
    server 127.127.1.0

    # Note that "restrict" applies to both servers and clients, so a configuration
    # that might be intended to block requests from certain clients could also end
    # up blocking replies from your own upstream servers.

    # By default, exchange time with everybody, but don't allow configuration.
    restrict -4 default kod notrap nomodify noquery
    restrict -6 default kod notrap nomodify noquery

    # Local users may interrogate the ntp server more closely.
    restrict 127.0.0.1
    restrict ::1

    # Clients from this (example!) subnet have unlimited access, but only if
    # cryptographically authenticated.
    restrict 192.168.1.0 mask 255.255.255.0 nomodify notrap

    # If you want to provide time to your local subnet, change the next line.
    # (Again, the address is an example only.)
    broadcast 192.168.1.255
    broadcastdelay 0.008

    # If you want to listen to time broadcasts on your local subnet, de-comment the
    # next lines. Please do this only if you trust everybody on the network!
    disable auth
    broadcastclient

    When I try from client #ntpdate 192.168.1.1
    the answer is:no server suitable for synchronization found

    Even if i try to synchronize from a web server like:
    #ntpdate pool.ntp.org
    the same answer:no server suitable for synchronization found

    Don't know where is the problem.
    ???

  2. #2
    Just Joined!
    Join Date
    Apr 2010
    Posts
    3
    Are you able to ping pool.ntp.org ?


    [root@server ~]# ntpdate pool.ntp.org
    15 Apr 20:25:00 ntpdate[31531]: adjust time server 72.18.205.156 offset 0.006033 sec
    [root@server ~]# ping pool.ntp.org
    PING pool.ntp.org (72.18.205.156) 56(84) bytes of data.
    64 bytes from mail.freerip.com (72.18.205.156): icmp_seq=1 ttl=52 time=21.4 ms
    64 bytes from mail.freerip.com (72.18.205.156): icmp_seq=2 ttl=52 time=21.6 ms
    64 bytes from mail.freerip.com (72.18.205.156): icmp_seq=3 ttl=52 time=21.6 ms
    ^C
    --- pool.ntp.org ping statistics ---
    3 packets transmitted, 3 received, 0% packet loss, time 2531ms
    rtt min/avg/max/mdev = 21.461/21.576/21.663/0.146 ms

    Do you know for sure that an ntp daemon (ntpd) is running on the 192.168.1.1 machine ? That is in the private non-routable ip-block.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •