Find the answer to your Linux question:
Results 1 to 3 of 3
Hi everybody! I am trying to mount a samba share which is on a network disk (host name hal). I can mount it from my laptop (host schmauck, Ubuntu 9.10), ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User Daan's Avatar
    Join Date
    Aug 2005
    Location
    The Netherlands
    Posts
    323

    Question Please help me connect to a SAMBA share


    Hi everybody!

    I am trying to mount a samba share which is on a network disk (host name hal). I can mount it from my laptop (host schmauck, Ubuntu 9.10), but I do not succeed to do it from my desktop (host thrix, Debian lenny).

    On my laptop:

    Code:
    root@schmauck:/home/daan# ls /mnt/hal/open/
    root@schmauck:/home/daan# mount -a
    root@schmauck:/home/daan# ls /mnt/hal/open/
    down  down1  movies  music  rips  soft  torrent
    root@schmauck:/home/daan# cat /etc/fstab
    # /etc/fstab: static file system information.
    #
    # Use 'blkid -o value -s UUID' to print the universally unique identifier
    # for a device; this may be used with UUID= as a more robust way to name
    # devices that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    # / was on /dev/sda5 during installation
    UUID=c7160a55-8736-4d11-bac0-92c91d95fa7d /               ext4    errors=remount-ro 0       1
    # swap was on /dev/sda6 during installation
    UUID=d64011b6-e0d8-44ab-a813-54fdd39eccbd none            swap    sw              0       0
    /dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
    # Added by Daan
    //hal/openshare	/mnt/hal/open	smbfs	credentials=/home/daan/.hal,uid=daan,gid=daan 0	0
    //hal/myshare	/mnt/hal/my	smbfs   credentials=/home/daan/.hal,uid=daan,gid=daan 0 0
    root@schmauck:/home/daan# ls -l /home/daan/.hal
    -rw-r--r-- 1 daan daan 36 2009-11-28 01:42 /home/daan/.hal
    root@schmauck:/home/daan# cat /etc/fstab
    On my desktop:

    Code:
    thrix:~# ls /mnt/hal/open
    thrix:~# mount -a
    mount error 13 = Permission denied
    Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
    mount error 13 = Permission denied
    Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
    thrix:~# cat /etc/fstab
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    /dev/hda1       /               ext3    errors=remount-ro 0       1
    /dev/hda6       /home           ext3    defaults        0       2
    /dev/hda5       none            swap    sw              0       0
    /dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0
    /dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
    //hal/openshare	/mnt/hal/open	smbfs	credentials=/home/daan/.hal,uid=daan,gid=daan 0	0
    //hal/myshare	/mnt/hal/my	smbfs   credentials=/home/daan/.hal,uid=daan,gid=daan 0 0
    
    thrix:~# ls -l /home/daan/.hal 
    -rw-r--r-- 1 daan daan 36 2009-11-28 01:42 /home/daan/.hal
    thrix:~#
    As you can see, fstab is the same on laptop and desktop, as is the credentials file. So I don't understand why I get permission denied.

    What did I forget?
    OS's I use: Debian testing, Debian stable, Ubuntu, OpenSuse 12.1, Windows 7, Windows Vista, Windows XP

  2. #2
    Linux Engineer rcgreen's Avatar
    Join Date
    May 2006
    Location
    the hills
    Posts
    1,134
    Do you have a hosts allow line in your smb.conf
    file on the server?

  3. #3
    Linux User Daan's Avatar
    Join Date
    Aug 2005
    Location
    The Netherlands
    Posts
    323
    Hi rcgreen,

    Here's the smb.conf of the server, which is a hacked network disk from LaCie.

    There's no hosts allow line:

    Code:
    HAL /root # cat /etc/samba/smb.conf
    [global]
        workgroup = LAN 
        server string = LaCie Network Space 
        security = user
        map to guest = bad user
        guest account = nobody
        log file = /var/log/samba/log.%m
        max log size = 50
        log level = 1
        socket options = TCP_NODELAY  
        interfaces = egiga0  
        dns proxy = no
        local master = yes
        os level = 20
        veto files = /lost+found/Network Trash Folder/TheVolumeSettingsFolder/Temporary Items/
        unix charset = UTF-8
        dos charset = CP437
        use sendfile = yes
        use mmap = yes
        Wide links = no
        unix extensions = no
    [kris]
        path = /home/myshare/kris
        vfs object = netatalk
        browseable = yes
        force user = root
        force group = users
        create mode = 0777
        write list = kris
        valid users = kris,
    [myshare]
        path = /home/myshare
        vfs object = netatalk
        browseable = yes
        force user = root
        force group = users
        create mode = 0777
        write list = admin
        valid users = admin,
    [openshare]
        path = /home/openshare
        vfs object = netatalk
        browseable = yes
        force user = root
        force group = users
        create mode = 0777
        guest ok = yes
    	  writeable = yes
        valid users = admin,@users,nobody
        write list = admin,nobody
        read list = @users
    I think the desktop and laptop have working groups different from the server (and maybe from each other). I'm not sure that matters, but I'll try to to find out.

    I just noticed that I can browse to the share using Nautilus.
    OS's I use: Debian testing, Debian stable, Ubuntu, OpenSuse 12.1, Windows 7, Windows Vista, Windows XP

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •