Find the answer to your Linux question:
Results 1 to 2 of 2
Hi, This is very old topic but despite of trying out all possible solutions available on net and forums, I am not able to setup tftp server on my 2.6.32.11-99.FC12.i686.PAE. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! charlie_arya's Avatar
    Join Date
    Sep 2009
    Posts
    39

    unable to set up TFTP on Fedora 12


    Hi,

    This is very old topic but despite of trying out all possible solutions available on net and forums, I am not able to setup tftp server on my 2.6.32.11-99.FC12.i686.PAE. Is there something obvious missing out.

    /etc/xinet.d/tftp


    # default: off
    # description: The tftp server serves files using the trivial file transfer \
    # protocol. The tftp protocol is often used to boot diskless \
    # workstations, download configuration files to network-aware printers, \
    # and to start the installation process for some operating systems.
    service tftp
    {
    disable = no
    socket_type = dgram
    protocol = udp
    wait = yes
    user = root
    server = /usr/sbin/in.tftpd
    server_args = -s -c /tftpboot
    per_source = 11
    cps = 100 2
    flags = IPv4
    }


    /etc/xinetd.conf


    #
    # This is the master xinetd configuration file. Settings in the
    # default section will be inherited by all service configurations
    # unless explicitly overridden in the service configuration. See
    # xinetd.conf in the man pages for a more detailed explanation of
    # these attributes.

    defaults
    {
    # The next two items are intended to be a quick access place to
    # temporarily enable or disable services.
    #
    enabled = tftp telnet
    # disabled =

    # Define general logging characteristics.
    log_type = SYSLOG daemon info
    log_on_failure = HOST
    log_on_success = PID HOST DURATION EXIT

    # Define access restriction defaults
    #
    # no_access =
    only_from = 192.168.*.*
    # max_load = 0
    cps = 50 10
    instances = 50
    per_source = 10

    # Address and networking defaults
    #
    # bind =
    # mdns = yes
    v6only = no

    # setup environmental attributes
    #
    # passenv =
    groups = yes
    umask = 002

    # Generally, banners are not used. This sets up their global defaults
    #
    # banner =
    # banner_fail =
    # banner_success =
    }

    includedir /etc/xinetd.d



    These are the configuration setting in my PC.
    I have done service xinetd --full-restart and then checked service --status-all. It showed xinetd (pid 4349) is running...
    Yet after all these I dont find tftp running on my PC.
    Please help me in setting tftp server on my PC. Its a kind of urgent.


    thanks
    -- RavS

  2. #2
    Linux Enthusiast
    Join Date
    Aug 2006
    Location
    Portsmouth, UK
    Posts
    539
    RHCE #100-015-395
    Please don't PM me with questions as no reply may offend, that's what the forums are for.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •