Find the answer to your Linux question:
Results 1 to 2 of 2
Hi all, I have an issue where postfix is setup to use dovecot auth and as far as I know it works, if i login using telnet to the mail ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2006
    Posts
    5

    [SOLVED] Postfix sasl issue from client


    Hi all,

    I have an issue where postfix is setup to use dovecot auth and as far as I know it works, if i login using telnet to the mail server i can authorize myself y providing the base64 encoded user & password. so if i can login, why cant my email clients. have tried thunderbird and evolution.

    this is the mail log relavant entries for sucessful login via telnet

    Code: (NOTE had to edit ips with --ip-- and emails with xxx an aaa to post)

    Code:
    May 13 23:30:26 horus postfix/smtpd[15207]: NOQUEUE: reject: RCPT from unknown[--ip--]: 554 5.7.1 <xxx>: Relay access denied; from=<aaa> to=<xxx> proto=ESMTP helo=<host>
    May 13 23:30:58 horus postfix/smtpd[15207]: D2354205CA: client=unknown[--ip--], sasl_method=plain, sasl_username=aaa
    and the failed attempt from mail client
    Code:

    Code:
    May 13 23:32:07 horus postfix/smtpd[15273]: warning: unknown[--ip--]: SASL PLAIN authentication failed: UGFzc3dvcmQ6
    May 13 23:32:10 horus postfix/smtpd[15273]: warning: unknown[--ip--]: SASL LOGIN authentication failed: UGFzc3dvcmQ6
    Login by pop or imap works flawlessly that what i dont get. From what i see it SHOULD be working.

    It it changes things, im using buntu server LTS 10.04 (I think thats the version) postfixadmin, postfix, dovecot. passwords and info stored in mysql tables. passwords are md5 encrypted. I thought that may be the issue, but that dosnt make sence.

    My best guess is that the email client is not encoding the details corectly.

  2. #2
    Just Joined!
    Join Date
    Sep 2006
    Posts
    5
    resolved this issue now, and on too a new issue. new post included

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •