Find the answer to your Linux question:
Results 1 to 4 of 4
I hope this is the correct sub-forum. I am running a few RHEL and Debian servers here at work, but have run into a bit of a problem. If i ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2008
    Posts
    47

    Issue with Reverse DNS lookups


    I hope this is the correct sub-forum.

    I am running a few RHEL and Debian servers here at work, but have run into a bit of a problem.

    If i use nsslookup or dig to look up a machine on our LAN by IP or name, i get the correct information returned.

    However when things are getting put into syslog, it is ONLY putting in the IP. As we use DHCP, the IP can be quite useless sometimes.

    eg:
    May 14 13:11:06 buzz runcvs[325]: connect from 172.16.65.10 (172.16.65.10)

    The network is a windows network, and the the linux boxes are all treated as standalone - ie there is no NIS or other software running.

  2. #2
    Just Joined!
    Join Date
    Mar 2008
    Posts
    47
    Anyone have any direction to point me in?

  3. #3
    Linux Enthusiast scathefire's Avatar
    Join Date
    Jan 2010
    Location
    Western Kentucky
    Posts
    626
    is the software in question set up to do DNS lookups? Are you using syslog-ng? I think it has a flag for setting DNS lookups as well. i think its something like:

    Code:
    use_dns(yes|no)
    linux user # 503963

  4. #4
    Just Joined!
    Join Date
    Mar 2008
    Posts
    47
    The software is just this:

    /usr/bin/cvs \
    -T /cvs/tmp \
    --allow-root=/cvs/AppDev \
    --allow-root=/cvs2/AppDevTest \
    pserver

    I have tried both the syslog-ng and the basic syslog but there is still no change. Im unsure of where to go with this. It has been wrecking my head for months, but i havent had the time to spend serious time trying to figure it out.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •