Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 15 of 15
Hello again ptkobe, I've been doing more tests on the network. First I tried is to disable DHCP from clients, and assign them static ip addresses. Then, when I disconnect ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Jul 2006
    Posts
    51

    Hello again ptkobe,

    I've been doing more tests on the network.

    First I tried is to disable DHCP from clients, and assign them static ip addresses.

    Then, when I disconnect the router from Internet, I saw that the problem with LAN connection still was there, so I thought that the problem coudn't be something of the DHCP server.

    Next step was trying to put the IP address of Samba Server as the DNS server into the TCP/IP configuration of Windows Clients, and then, when I disconnect the router from Internet, the LAN connections were perfect, but obviously, after connecting the the router again, the clients didn't have access to internet.

    So, there must be a relation between these things...

    It seems that clients try to locate the Samba Server into the DNS Internet Server in spite of not indicating it.

    Is it giving you some more clues?

    Aleix

  2. #12
    Linux User ptkobe's Avatar
    Join Date
    Feb 2008
    Location
    Torres Vedras, PT
    Posts
    276
    Let's consider it's a dns problem with your windows clients, as it sounds it is.

    Please see if your samba server ip appears as the wins server on your windows clients?

    See status -> support -> details on the device

    if it is not, set it by hand on the device TCP/IP properties -> Advanced -> wins, set the dns to automatic and give it a try.

    Note: if this was just a dns problem, I would say to you to set a local dns server. It has several advantages, even for a small LAN.
    But I think you should be able to use wins, if what you do is using the windows workgroup to share files between machines. As you know, there are other solutions that use dns (not wins), from ftp, http, to ssh and cvs, for example.

    Your decision if you want to pursue the wins for a bit longer. Unfortunately I am no expert (even near) on that subject.
    On thing that may (or not) concern your problem is that AFAIK wins is not a typical server/client implementation (it is often called distributed) as when the present server is turned off, another one on the LAN takes it place.

    Wish someone else could give you more help
    Regards
    Luis

  3. #13
    Linux Guru
    Join Date
    Nov 2007
    Posts
    1,761
    This is no mystery.

    Review your config from the *client's* perspective. If you want to remove name resolution as a possible cause, test by connecting to the server's IP from the client.
    If you attach to a CIFS share via \\IP_ADDRESS, there is no name lookup required, so name resolution is removed from the process.

    If using a hostname, Windows must resolve it. The *default* name resolution order for Windows is 1) is this hostname the local machine? 2) is it in a hosts or lmhosts file? 3) DNS 4) WINS 5) NetBIOS (WINS is nothing more than a centralized, cross-network NetBIOS implementation.)

    As documented by MSFT.

    The client will wait for DNS to timeout, then move on to NetBIOS broadcasts. The *best* solution for a small office is either to put all hosts into every machine's hosts file, or run a small local DNS server. Your office DNS server should forward any requests not for your local domain to your ISP's DNS server. Problem solved.

    You can find more information about how name resolution works via Google and more in depth Windows help on an appropriate forum.

    * Just due to my general dislike of the network "spam" caused by NetBIOS, I would also disable NetBIOS as well.

  4. $spacer_open
    $spacer_close
  5. #14
    Linux User ptkobe's Avatar
    Join Date
    Feb 2008
    Location
    Torres Vedras, PT
    Posts
    276
    So, there it is, aleix

    I thought windows would try to resolve names using wins first (as apparently your samba server does), and you could get bye without setting host files or a local/forward DNS server.

    That is, keep using the external DNS servers when you have internet, and wins when you don't.

    As it is, it seems the above, as explained in HROAdmin26 post, are your options.

    I saw an article about changing resolve name order, on Windows 95 and Windows NT
    How to change name resolution order on Windows 95 and Windows NT
    but it involves changing the registry. What I don't like to do, as a general rule. So, if that's the way, I don't like it or recommend. But that's me.

    Regards
    Luis

  6. #15
    Just Joined!
    Join Date
    Jul 2006
    Posts
    51

    Resume

    Hi guys, thanks for all your help.

    I think that we have tried such things that at this moment you are so confused as I am...

    I read all the posts again to clean my mind, and correct some of the clues, because I've done more tests and some of my posts has some error, so here is a resume of the situation (it is necessary for me to start from the begining).

    Well, I could simplify de network structure, because disconnecting the PROXY from the LAN SWITCH causes de same problem, so now, to simplify the network this is the new situation:



    Ok, then, the Samba Server is configured as a PDC (Primary Domain Controller) of the domain "DOMAIN".
    • The WinXP clients, are into the domain "DOMAIN".
    • The Linux Client, has the workgroup parameter: workgroup = DOMAIN


    The network configurations of the computers are:
    • WinXP: 192.168.0.2
    • WinXP: 192.168.0.4
    • PDC (Samba Srever): 192.168.0.5
    • Linux client: 192.168.0.8
    • All of them has the PROXY IP as a GATEWAY to Internet.
    • All of them have the ISP DNS configured.


    Moreover, the WinXP clients have the 192.168.0.5 IP as their WINS server (I've tried putting it manually and from DHCP server too).

    PROBLEM:
    • Finally, the problem is that disconnecting the PROXY from the SWITCH causes an extremely slow connection (most times timeout) from the clients TO the PDC (Samba Server).
    • This problem is from ALL the clients (included the Linux client) TO just the PDC (connection from 1 client to another client is fine).


    However, the PING command works fine from everywere to everywere (using Ping IPaddress and Ping HOSTNAME too)!!

    I can't access to the PDC writing the HOSTNAME and neither writing directly the IP address.

    In one of my posts I said that configuring 192.168.0.5 as the DNS of the clients made it work, but trying it again gives me the same bad result, so please forgive me for that lie...

    I have also tried your suggestions of changing the name resolution order in the Windows registry as Microsoft help explains on their website.

    All these tests make me think that the problem must be on the Samba Server, don't you think?

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •