Find the answer to your Linux question:
Results 1 to 3 of 3
Hello, thats my first post here! i read through a bit and searched the forums but couldn't find a solution that applies on my problem: i have a server (debian ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2010
    Location
    Austria
    Posts
    2

    php mail function not working, no error returned


    Hello,

    thats my first post here! i read through a bit and searched the forums but couldn't find a solution that applies on my problem:

    i have a server (debian lenny) with zimbra collaboration suite installed. therefore i had to deactivate exim4 (the default mta?). i suspect, that exim4 was kind of linked to the command "sendmail", so that now the php mail function is now not working (php mail calls sendmail, right?).

    so how can i, or how did you, resolve the problem?
    i thought about changing the port of exim4, but couldn't find any config file. eximconfig doesn't work either.

    i hope to get some valueable information here, to help me get this annoying problem solved.

    best regards!

    (and, if any, i apologise for my spelling errors! -> english is not my mother tongue)

  2. #2
    Just Joined!
    Join Date
    Jul 2006
    Posts
    51
    Hi godmod,

    welcome to the forum,

    did you try a simple php file like this?

    Code:
    <?php 
    mail($vars...);
    ?>
    Do you have all "display errors" enabled on your php.ini file?

  3. #3
    Just Joined!
    Join Date
    May 2010
    Location
    Austria
    Posts
    2
    hi aleix,

    thanks for your reply. i handled the problem reconfiguring exim. both, a simple php file as well as wordpress & co are now able to drop mails from the box.

    anyways, the problem only occured because i wasn't able to change the port of exim :/

    regards

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •