Find the answer to your Linux question:
Results 1 to 3 of 3
This isn't so much a linux question as it is a question about setting up a server. A while back, i set up a WAMP server and everything was working ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2008
    Posts
    59

    PHP and Perl?


    This isn't so much a linux question as it is a question about setting up a server.
    A while back, i set up a WAMP server and everything was working fine. Today, I noticed that the test PHP scripts that worked before now don't. I'm thinking that something about the way I configured Perl is conflicting with the way PHP was configured. (Perl seems to be working fine) Is it possible to have both on a server or do you have to pick one?

    I can't remember if I tried to do anything with PHP after I set up Perl, but I haven't changed anything with how Apache is configured since then, and I can't think of any other reason these scripts suddenly don't work.

    Relevant excerpts from Apache configuration file:
    Code:
    PHPIniDir "C:/Program Files/PHP"
    ScriptAlias /php/ "C:\Program Files\PHP"
    <Directory "C:\Program Files\PHP">
        AllowOverride None
        Options None
        Order allow,deny
        Allow from all
    </Directory>
    AddType application/x-httpd-php .php
    AddHandler cgi-script .cgi .pl
    LoadModule php5_module "C:/Program Files/PHP/php5apache2_2.dll"
    #Action application/x-httpd-php "C:\Program Files\PHP\php-cgi.exe"
    Options Indexes FollowSymLinks ExecCGI
    LoadModule cgi_module modules/mod_cgi.so

  2. #2
    Linux Enthusiast scathefire's Avatar
    Join Date
    Jan 2010
    Location
    Western Kentucky
    Posts
    626
    they are two different languages. i find it hard to believe that one would really affect the other. are there any error messages in your logs that give an indication as to what maybe wrong?
    linux user # 503963

  3. #3
    Just Joined!
    Join Date
    Sep 2008
    Posts
    59
    I couldn't really find any errors, but this shows up more than once in the log:
    [warn] pid file C:/Program Files/Apache Software Foundation/Apache2.2/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
    [Wed Jul 28 11:09:13 2010] [notice] Apache/2.2.11 (Win32) PHP/5.2.9-2 configured -- resuming normal operations
    I had PHP files that worked before, I haven't done anything with them in a while, and now they don't work, and I have no idea why. The only thing I could think of was that these files were created before I configured Perl, and perhaps something with how I configured Perl in the configuration file caused something that's supposed to be pointing to PHP to now be pointing to Perl, making the server unable to find the PHP engine, thus making the program not work.

    That might not be the problem at all, that was the only thing I could think of. It was a long time ago when I configured this stuff, so I don't completely remember what I did or when I did it.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •