Find the answer to your Linux question:
Results 1 to 4 of 4
I have a running Apache 2.2.16 + PHP 5.3.3 and MySQL 5.(something, can't remember as I have my morning coffee, it's the latest as of last week). All are installed ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! mphare's Avatar
    Join Date
    Jul 2010
    Posts
    2

    Apache 2.2 and OpenSSL 1.0, no fun in paradise


    I have a running Apache 2.2.16 + PHP 5.3.3 and MySQL 5.(something, can't remember as I have my morning coffee, it's the latest as of last week). All are installed from source. I have a few apache modules compiled in: mod_rewrite mod_authz_lapd and mod_lapd. I thought I'd go for broke and compile in ssl.
    I downloaded OpenSSL 1.0.0a and compiled it. I am able to generate a self signed cert with 1.0.0a.

    When I compile apache with --enable-ssl and --with-ssl, I get an error related to an unknown call to SSL_get_servername. So I tried making ssl a dynamic load module. mod_ssl.so is created in the modules directory and the compile completes. I add a LoadModule statement to the conf file, but when I go to start apache I get a similar error related to SSL_get_servername.

    I must have done something fundamentally wrong, but I cannot determine what that is. Anyone have any insight into this problem?

    Thanks,

    Mike

  2. #2
    Linux Enthusiast Mudgen's Avatar
    Join Date
    Feb 2007
    Location
    Virginia
    Posts
    664
    There's a bug report on ASF Bugzilla that suggests that this may be due to make getting crossed-up over multiple SSL packages being present.

    https://issues.apache.org/bugzilla/s...g.cgi?id=48880

  3. #3
    Just Joined! mphare's Avatar
    Join Date
    Jul 2010
    Posts
    2
    Hi and Thanks for the reply.
    I did see that report, but didn't catch what to do to fix this.

    I am not the SA of the system and I cannot upgrade or uninstall the root apps/libs as the report suggests. So I am installing in a local directory. I've built and installed zLib 1.2.5, OpenSSL 1.0.0a (with zLib) and Apache 2.2.16 with --enable-ssl and --with-ssl) what I don't understand is how to make the build look at my installation and not the system root installation (there is OpenSSL 0.9.8? in the root). I've set LD_LIBRARY_PATH, C_INCLUDE_PATH and CPLUS_INCLUDE_PATH to point to my local dirs. What else do I need to do?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast Mudgen's Avatar
    Join Date
    Feb 2007
    Location
    Virginia
    Posts
    664
    Have you tried the "--with-ssl=<your ssl location>" similar to the last post in the bug report?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •