Find the answer to your Linux question:
Results 1 to 3 of 3
I'm having trouble connecting my windows 7 machine to my Samba server that i set up on a FreeBSD VM. The FreeBSD version is 7.2 and the samba version is ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2010
    Posts
    2

    Windows 7 connect to FreeBSD samba


    I'm having trouble connecting my windows 7 machine to my Samba server that i set up on a FreeBSD VM. The FreeBSD version is 7.2 and the samba version is 3.

    I followed the directions here mrp3.com/windows-to-unix-samba.html to set it up as a domain controller exactly.. except for adding the samba_dns_update script because i didn't find it being asked for in the config file.

    The name of my Windows computer is Pushkin-PC so like it says in the script I added it using adduser and put it under the machines group. I added it as Pushkin-PC$ though.. as the site showed. then I did smbpasswd -a Pushkin-PC$ which also made me make a password.

    Then the script said to finalize it by doing the command smbpasswd -m Pushkin-PC$ .. but when I executed that command i got the errors:

    Failed to set password for user Pushkin-PC$.
    Failed to modify password entry for user Pushkin-PC$.

    I couldn't figure out why...

    Here's my config file.. all the uncommented parts:

    server string = WORKGROUP
    server string = Samba Server
    security = user
    hosts allow = 192.168.1 192.168.2 127.
    load printers = yes
    printing = cups
    log file = /var/log/samba/log.%m
    max log size = 50
    passdb backend = tdbsam
    include = /usr/local/etc/smb.conf.%m
    local master = yes
    os level = 33
    domain master = yes
    preferred master = auto
    domain logons = yes
    logon path = \\%L\Profiles\%U
    wins support = yes
    dns proxy = no
    add user script = /usr/local/sbin/smb-add-user %u
    add group script = /usr/local/sbin/smb-add-group %g
    add machine script = /usr/local/sbin/smb-add-machine %u
    add user to group script = /usr/local/sbin/smb-add-user-group %u %g
    delete user script = /usr/local/sbin/smb-rm-user %u
    delete user from group script = /usr/local/sbin/smb-rm-user-group %u %g
    delete group script = /usr/local/sbin/smb-rm-group %g

    [homes]
    comment = Home Directories
    browseable = no
    writeable = yes

    [netlogon]
    comment = Network Logon Service
    path = /usr/local/lib/samba/netlogon
    guest ok = yes
    writeable = no
    share modes = no

    [profiles]
    path = /usr/local/lib/samba/profiles
    browseable = no
    guest ok = yes

    [printers]
    comment =All Pringers
    path = /var/spool/samba
    browseable = no
    guest ok = no
    writeable = no
    printable = yes


    anyways, when try to connect my windows pc (Pushin-PC) to samba.. i do the following command:

    \\192.168.198.137\Pushkin-PC$

    the ip is the freebsd's ip running samba.

    and I get the following error: The network path was not found.

    Help?

  2. #2
    RDU
    RDU is offline
    Just Joined!
    Join Date
    Aug 2010
    Posts
    89
    1.To use samba as a domain controler for Windows 7 client, your need at least release 3.3 and set 2 registry key in windows 7 clients : Windows7 - SambaWiki
    2.To add your client computer you have to smbpasswd -a -m xxxxxx
    -a for Add ; -m for machine account
    3.Then you need to define a USER account (a unix user has to exist, then smbpasswd -a yyyyy)
    4.When you access, you need to do \\192.168.198.137\ShareName where sharename is one of the share defined in your smb.conf (at the moment, you have only user defined, so the share name would be the username and it should go to the home directory of this unix user). You can add a new section in smb.conf e.g. to add a common share :
    [common]
    comment=common documents
    path=/data
    browseable=yes
    writeable=yes

    Then create the /data folder with the correct access right.

  3. #3
    Linux Guru
    Join Date
    Nov 2007
    Posts
    1,759
    The biggest issue I have seen with 2008R2 and Win 7 and Samba connectivity is the fact that MSFT made "use NTLMv2 only" the default for LAN Manager authentication. Setting Win 7 to "Send LM and NTLM - use NTLMv2 if negotiated" usually allows authentication.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •