Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 16 of 16
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11

    I've also tried this:

    <Directory /home/webadmin/>
    Options Indexes Includes FollowSymLinks
    AllowOverride All

  2. #12

    Where I am at now


    This is what I have for my VirtualHost entry now
    DocumentRoot /home/webadmin/
    <Directory "/home/webadmin/">
    # Possible values for the Options directive are "None", "All",
    # or any combination of&#58;
    #   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
        Options Indexes FollowSymLinks
        AllowOverride None
        Order allow,deny
        Allow from all
    I feel like this should work, but I am still getting a permissions error. The directories all have Traversal set and permissions are all 777.

    Any ideas?

  3. #13
    Linux Guru
    Join Date
    Oct 2001
    Täby, Sweden
    That "ServerName" seems suspicious. Isn't it supposed to be "ServerName"?

  4. $spacer_open
  5. #14
    Quote Originally Posted by Dolda2000
    That "ServerName" seems suspicious. Isn't it supposed to be "ServerName"?
    Tried that before and that didn't make a difference. Is this attribute even necessary? I don't have the domain pointed to this server anyway. I will be referring to it via IP.

  6. #15

    SELinux chcon

    If you're running SElinux (more secure) then you may have to change the "security context" with chcon.

    ls -lZ

    will give you a long format directory listing. If you are running SE, it will have an additional attribute, the security context. which might look like


    for the pages to be served you need to change the context to user_u:object_r:httpd_sys_content_t

    which can be done with

    chcon -t httpd_sys_content_t filename

    Or you could disable SELinux, and not have to worry about it.
    If that's not your issue, I'm not sure.

  7. #16
    Just Joined!
    Join Date
    Oct 2005
    North Carolina, USA
    Maybe too obvious, but did you remember to set User and Group directives in the httpd config file so that your server is running as webadmin in the users group?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts