Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 16 of 16
I've also tried this: <Directory /home/webadmin/daveturkington.com/html> Options Indexes Includes FollowSymLinks AllowOverride All </Directory>...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Nov 2004
    Posts
    11

    I've also tried this:

    <Directory /home/webadmin/daveturkington.com/html>
    Options Indexes Includes FollowSymLinks
    AllowOverride All
    </Directory>

  2. #12
    Just Joined!
    Join Date
    Nov 2004
    Posts
    11

    Where I am at now

    Hi,

    This is what I have for my VirtualHost entry now
    Code:
    <VirtualHost 192.168.0.100&#58;9001>
    ServerAdmin email@domain.com
    DocumentRoot /home/webadmin/domain.com/html
    ServerName 192.168.0.100
    <Directory "/home/webadmin/domain.com/html/">
    # Possible values for the Options directive are "None", "All",
    # or any combination of&#58;
    #   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
    #
        Options Indexes FollowSymLinks
        AllowOverride None
        Order allow,deny
        Allow from all
    
    </Directory>
    </VirtualHost>
    I feel like this should work, but I am still getting a permissions error. The directories all have Traversal set and permissions are all 777.

    Any ideas?

  3. #13
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    That "ServerName 192.168.0.100" seems suspicious. Isn't it supposed to be "ServerName domain.com"?

  4. #14
    Just Joined!
    Join Date
    Nov 2004
    Posts
    11
    Quote Originally Posted by Dolda2000
    That "ServerName 192.168.0.100" seems suspicious. Isn't it supposed to be "ServerName domain.com"?
    Tried that before and that didn't make a difference. Is this attribute even necessary? I don't have the domain pointed to this server anyway. I will be referring to it via IP.

  5. #15
    Just Joined!
    Join Date
    Dec 2005
    Posts
    1

    SELinux chcon

    If you're running SElinux (more secure) then you may have to change the "security context" with chcon.

    ls -lZ

    will give you a long format directory listing. If you are running SE, it will have an additional attribute, the security context. which might look like

    user_u:object_r:user_home_t

    for the pages to be served you need to change the context to user_u:object_r:httpd_sys_content_t

    which can be done with

    chcon -t httpd_sys_content_t filename

    Or you could disable SELinux, and not have to worry about it.
    If that's not your issue, I'm not sure.

  6. #16
    Just Joined!
    Join Date
    Oct 2005
    Location
    North Carolina, USA
    Posts
    45
    Maybe too obvious, but did you remember to set User and Group directives in the httpd config file so that your server is running as webadmin in the users group?

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •