Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
Hi, I have installed OTRS on a Centos Machine, When I tried to configure the data base using a browser by accessing installer.pl it is showing this error Permission denied ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    vkv
    vkv is offline
    Just Joined!
    Join Date
    Apr 2010
    Posts
    29

    Question installing OTRS


    Hi,

    I have installed OTRS on a Centos Machine,

    When I tried to configure the data base using a browser by accessing installer.pl

    it is showing this error

    Permission denied at /opt/otrs/bin/cgi-bin/../../Kernel/System/Log.pm line 230.



    When I tried to access the Otrs folder through the same browser it is showing permission denied

    But my apache works fine

    Please Help me out in this issue , I need to install a ticketing system on my server

    Or else Please help me out to find out a good ticketing system to install in server so that all client machine can access that, Our client machines are UBUNTU,WIN7,WIN vista

    Please Help me

  2. #2
    Just Joined!
    Join Date
    Jul 2009
    Location
    uk
    Posts
    22
    Hi vkv,


    I am not a expert and also i have not used OTRS before but sorry if these sounds abit stupid, have you made sure that the directories have the right permissions and also make sure the .pl file is executable.


    Only a suggestion though!

  3. #3
    vkv
    vkv is offline
    Just Joined!
    Join Date
    Apr 2010
    Posts
    29
    All directories have the right permissions and when i tried to access the otrs folder using a browser from a Client it is showing like "You are forbidden to use this folder"

    The .pl file is executable I checked

    So is this a permission issue or software issue?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jul 2009
    Location
    uk
    Posts
    22
    Sorry for the late reply i have been a bit busy.

    I have done abit of perl , but not a great deal so if anyone can correct me if im wrong that will be great. I believe it is a permission problem somewhere as if there was any errors with the file etc it would come up internal error, but there could be 2 other possible causes for this.

    I guess your using apache ?

    If not i cant give any advice has i really only use apache. If it is apache, perl files normally run in the /cgi-bin directory but can also use any other directory if its setup right in the apache virtual host. ( I see its running in /opt, problem could be there ie permissions! )

    Have you run other perl files before on the web server and do they do the same?

    The last thing i can think of is its possible there's a .htaccess file in the OTRS directory which is overriding the normal permission stopping it being accessed.
    Other than these i can't think of any thing else what could be wrong, i'm sure its something simple as in the configuration in the .htaccess or something wrong in the apache virtual host, but if you have run other perl scripts before then it won't be the apache configuration.

    Sorry i can't much help , as i said i have done a bit of this but not alot.

  6. #5
    vkv
    vkv is offline
    Just Joined!
    Join Date
    Apr 2010
    Posts
    29
    Thanks for the reply. Lemme check out that and I'll update you

  7. #6
    Just Joined!
    Join Date
    Jul 2009
    Location
    uk
    Posts
    22
    Thats ok, hope it helps you! Yeh np !

  8. #7
    vkv
    vkv is offline
    Just Joined!
    Join Date
    Apr 2010
    Posts
    29
    I checked, I can Run other .pl files, So i think the issue is with otrs. What I have to change in the .htaccess file to change the permissions ? Please help me

    Thanks in Advance

  9. #8
    Just Joined!
    Join Date
    Jul 2009
    Location
    uk
    Posts
    22
    Right ok, i have downloaded the otrs myself and i can not see a .htaccess file anywhere so it wont be this.

    Have you disabled selinux if not do this :-


    If you are using gui go to the selinux settings in Settings > Administration > selinux management and select disabled then restart machine

    Or if at the commandline as root "nano /etc/selinux/config then where it says SELINUX

    change to

    SELINUX=disabled and save it

    then restart machine

    then once started up run the commands

    service httpd start
    service mysqld start
    service otrs start

    again then go back to the broswer and rerun the installer.pl then it should work

  10. #9
    vkv
    vkv is offline
    Just Joined!
    Join Date
    Apr 2010
    Posts
    29
    Sorry to disturb you like this ,

    I already disabled SELINUX , The the funny part is the same package worked on other Centos machine. only in this machine it is not working

    Advance Thanks

  11. #10
    Just Joined!
    Join Date
    Jul 2009
    Location
    uk
    Posts
    22
    Right ok that seems abit weird has i have tried it on rhel which centos is based on and i get the same error when running the installer.pl what you get, but it ggoes away when disabling selinux. So i would suggest re-downaloding and installing the otrs package again has if another machine with centos works and the other one dont, then there must be something wrong with the package.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •