Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
Hi All I am a newbie with linux and I am trying to configure sendmail on a CentOS box. My sendmail in configured on a internal Lan ip machine where ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2010
    Posts
    8

    Unhappy Sendmail DSN: unavailable service Error


    Hi All
    I am a newbie with linux and I am trying to configure sendmail on a CentOS box.
    My sendmail in configured on a internal Lan ip machine where as the DNS server is on another machine. when i am trying to send email from the machine the log file show the error as 5.0.0 dsn:unavailable service but i can send emails to gmail using the same sendmail.

    I am very much in need to solve this

    Thanks in advance

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,845
    This is probably a DNS problem. Make sure that the mail server is pointed at the correct DNS server in /etc/resolve.conf, and that the DNS server is returning the correct MX address for the domains it is serving.

    Your mail clients are getting external MX address correctly because you DNS machine is forwarding requests for domains it doesn't know about, but as soon as someone tries to send an email to an address on your mail server, a missing MX record would mean it doesn't know where to send it.
    Linux user #126863 - see http://linuxcounter.net/

  3. #3
    Just Joined!
    Join Date
    Aug 2010
    Posts
    8
    Thank you for the reply ROXOFF
    Sorry ...

    Can you please brief it out more as i am not good with the DNS ...

    But mean while I have tried with the sendmail from the Server where dns is installed that works fine.
    So any possibility where the DNS server is not allowing to resolve for the ip addresses with in the LAN as the DNS server is on STATIC IP.



  4. #4
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,845
    If your DNS machine is getting name lookups resolving correctly, then everything is working great - except your mail server which cannot do the correct DNS lookups.

    Check the nameserver settings on your email server. This is configured through /etc/resolve.conf, but if you use DHCP it'll get overwritten when your IP address is renwed. Normally you'd put your mail server on a static IP address, so that's probably what the problem is - everything else on your LAN is using DHCP but the mail server isn't, and its DNS config is out of step with the DHCP server's.

    As you're running CentOS, you should be able to use system-config-network to set the DNS address correctly.
    Linux user #126863 - see http://linuxcounter.net/

  5. #5
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,677
    It could be the place were you are trying to send email to doesn't have its MX records setup properly. You can check this with DIG.

    dig domain mx

    Replacing domain with the domain you are trying to send mail to.
    It should look something like the following:

    Code:
    ~ $ dig redhat.com mx
    
    ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-4.P1.el5_4.2 <<>> redhat.com mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 42350
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 3, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;redhat.com.                    IN      MX
    
    ;; ANSWER SECTION:
    redhat.com.             600     IN      MX      10 mx2.redhat.com.
    redhat.com.             600     IN      MX      5 mx1.redhat.com.
    
    ;; AUTHORITY SECTION:
    redhat.com.             69      IN      NS      ns3.redhat.com.
    redhat.com.             69      IN      NS      ns1.redhat.com.
    redhat.com.             69      IN      NS      ns2.redhat.com.
    
    ;; ADDITIONAL SECTION:
    mx1.redhat.com.         600     IN      A       209.132.183.28
    mx2.redhat.com.         600     IN      A       66.187.233.33
    
    ;; Query time: 64 msec
    ;; SERVER: 192.168.1.254#53(192.168.1.254)
    ;; WHEN: Sat Aug 21 09:27:54 2010
    ;; MSG SIZE  rcvd: 154

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

  6. #6
    Just Joined!
    Join Date
    Aug 2010
    Posts
    8
    Thanks for the reply Lazydog.

    I was just going through the DNS and I can resolve the domain from the same system where as i am unable to resolve from any other system which is in LAN. I am pasting the result of the dig command please suggest me if any changes are to be made

    Thanks in advance

    Code:
    dig mydomain.com mx
    
    ; <<>> DiG 9.6.1-P1 <<>> mydomain.com mx
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 38239
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;mydomain.com.                 IN      MX
    
    ;; AUTHORITY SECTION:
    mydomain.com.          86400   IN      SOA     solutions.mydomain.com. root.so
    
    ;; Query time: 0 msec
    ;; SERVER: 192.168.10.39#53(192.168.10.39)
    ;; WHEN: Mon Aug 30 16:51:16 2010
    ;; MSG SIZE  rcvd: 82

  7. #7
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,677
    What you show above doesn't show that any MX records are setup as there is no ANSWER SECTION: in the output.

    You need to setup the MX records in the zone file.
    Below is the output from the internet for mydoamin.com:

    Code:
    ~ $ dig mydomain.com mx
    
    ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-4.P1.el5_4.2 <<>> mydomain.com mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 33406
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 4, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;mydomain.com.                  IN      MX
    
    ;; ANSWER SECTION:
    mydomain.com.           86400   IN      MX      0 mx.mailix.net.
    
    ;; AUTHORITY SECTION:
    mydomain.com.           1800    IN      NS      ns1.mydomain.com.
    mydomain.com.           1800    IN      NS      ns2.mydomain.com.
    mydomain.com.           1800    IN      NS      ns3.mydomain.com.
    mydomain.com.           1800    IN      NS      ns4.mydomain.com.
    
    ;; Query time: 163 msec
    ;; SERVER: 192.168.1.254#53(192.168.1.254)
    ;; WHEN: Tue Aug 31 13:53:30 2010
    ;; MSG SIZE  rcvd: 131
    You see how it has an ANSWER SECTION:?

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

  8. #8
    Just Joined!
    Join Date
    Aug 2010
    Posts
    8
    Hi Lazydog,

    Thanks a lot for getting me back.

    I am not that good with DNS records, Can you please provide me with some details where i need to make changes in forward.zone, reverse.zone files.

  9. #9
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,677
    MX records are in the FORWARD zone. MX records point to a host not an IP Address.
    Take a look and read HERE

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

  10. #10
    Just Joined!
    Join Date
    Aug 2010
    Posts
    8
    Thanks all for the reply but for some reason iam not able to resolve the thing. as of now i can dig and i get the Answer section too.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •