Find the answer to your Linux question:
Results 1 to 2 of 2
Hi Guys, I'm fairly new to linux but have managed to get a LAMP installation up and running on a openSuse 11.3 install. The issue i'm having at the mo ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2010
    Posts
    4

    [SOLVED] vsftp with dreamweaver


    Hi Guys,

    I'm fairly new to linux but have managed to get a LAMP installation up and running on a openSuse 11.3 install.

    The issue i'm having at the mo is with vsftp, I've set it up and it works remotely with the users chrooted to their home folders. However when I try and upload to a home folder through the ftp in dreamweaver I get the following message

    "An ftp error occurred - cannot put xxxxx.html Access Denied. The file may not exit or there could be a permission problem"

    The strange thing is, if I comment out chroot_local_user in the vsftp conf then I can ftp upload to the root of the ftp folder no problem.

    I have tried a variety of different conf setups and got no where so any help would be much appriciated.

    Cheers

    Ali

    p.s if you would like me to post confs I can do.

  2. #2
    Just Joined!
    Join Date
    Nov 2010
    Posts
    4
    Looks like I've sorted it, the upload folder specified in dreamweaver was not a member of the ftp-users group I created. Changed the group membership and its now sorted. For anyone who might read this with the same problem the syntax was

    cd /path/to/the/folder/containing/the/folder/you/want/to/change

    chown <username>:<group name> <foldername>

    do this without tyhe <> but include the :

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •