Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
Howdy, I need some help here. vsftpd isn't letting me in. I'm running Fedora 13, and trying to access it from Vista using FileZilla. It lets me in as anonymous ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2010
    Location
    Portland, OR
    Posts
    7

    vsftpd '550 Permission denied' on Fedora


    Howdy,

    I need some help here. vsftpd isn't letting me in. I'm running Fedora 13, and trying to access it from Vista using FileZilla.

    It lets me in as anonymous everytime, but anonymous users logged into different folder, not what I need. Idk why, here what FileZilla outputs when I attempt to log in as a user (that exists and work on Linux machine):

    Command: USER Roman
    Response: 530 Permission denied.
    Error: Could not connect to server
    vsftpd.conf file:
    Example config file /etc/vsftpd/vsftpd.conf
    #
    # The default compiled in settings are fairly paranoid. This sample file
    # loosens things up a bit, to make the ftp daemon more usable.
    # Please see vsftpd.conf.5 for all compiled in defaults.
    #
    # READ THIS: This example file is NOT an exhaustive list of vsftpd options.
    # Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
    # capabilities.
    #
    # Allow anonymous FTP? (Beware - allowed by default if you comment this out).
    anonymous_enable=YES
    #
    # Uncomment this to allow local users to log in.
    local_enable=YES
    #
    # Uncomment this to enable any form of FTP write command.
    write_enable=YES
    #
    # Default umask for local users is 077. You may wish to change this to 022,
    # if your users expect that (022 is used by most other ftpd's)
    local_umask=022
    #
    # Uncomment this to allow the anonymous FTP user to upload files. This only
    # has an effect if the above global write enable is activated. Also, you will
    # obviously need to create a directory writable by the FTP user.
    #anon_upload_enable=YES
    #
    # Uncomment this if you want the anonymous FTP user to be able to create
    # new directories.
    anon_mkdir_write_enable=YES
    #
    # Activate directory messages - messages given to remote users when they
    # go into a certain directory.
    dirmessage_enable=YES
    #
    # Activate logging of uploads/downloads.
    xferlog_enable=YES
    #
    # Make sure PORT transfer connections originate from port 20 (ftp-data).
    connect_from_port_20=YES
    #
    # If you want, you can arrange for uploaded anonymous files to be owned by
    # a different user. Note! Using "root" for uploaded files is not
    # recommended!
    #chown_uploads=YES
    #chown_username=whoever
    #
    # You may override where the log file goes if you like. The default is shown
    # below.
    #xferlog_file=/var/log/vsftpd.log
    #
    # If you want, you can have your log file in standard ftpd xferlog format.
    # Note that the default log file location is /var/log/xferlog in this case.
    xferlog_std_format=YES
    #
    # You may change the default value for timing out an idle session.
    #idle_session_timeout=600
    #
    # You may change the default value for timing out a data connection.
    #data_connection_timeout=120
    #
    # It is recommended that you define on your system a unique user which the
    # ftp server can use as a totally isolated and unprivileged user.
    #nopriv_user=ftpsecure
    #
    # Enable this and the server will recognise asynchronous ABOR requests. Not
    # recommended for security (the code is non-trivial). Not enabling it,
    # however, may confuse older FTP clients.
    #async_abor_enable=YES
    #
    # By default the server will pretend to allow ASCII mode but in fact ignore
    # the request. Turn on the below options to have the server actually do ASCII
    # mangling on files when in ASCII mode.
    # Beware that on some FTP servers, ASCII support allows a denial of service
    # attack (DoS) via the command "SIZE /big/file" in ASCII mode. vsftpd
    # predicted this attack and has always been safe, reporting the size of the
    # raw file.
    # ASCII mangling is a horrible feature of the protocol.
    #ascii_upload_enable=YES
    #ascii_download_enable=YES
    #
    # You may fully customise the login banner string:
    #ftpd_banner=Welcome to Daniel & Roman FTP server.
    #
    # You may specify a file of disallowed anonymous e-mail addresses. Apparently
    # useful for combatting certain DoS attacks.
    #deny_email_enable=YES
    # (default follows)
    #banned_email_file=/etc/vsftpd/banned_emails
    #
    # You may specify an explicit list of local users to chroot() to their home
    # directory. If chroot_local_user is YES, then this list becomes a list of
    # users to NOT chroot().
    #chroot_local_user=YES
    #chroot_list_enable=YES
    # (default follows)
    chroot_list_file=/etc/vsftpd/chroot_list
    #
    # You may activate the "-R" option to the builtin ls. This is disabled by
    # default to avoid remote users being able to cause excessive I/O on large
    # sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
    # the presence of the "-R" option, so there is a strong case for enabling it.
    #ls_recurse_enable=YES
    #
    # When "listen" directive is enabled, vsftpd runs in standalone mode and
    # listens on IPv4 sockets. This directive cannot be used in conjunction
    # with the listen_ipv6 directive.
    listen=YES
    #
    # This directive enables listening on IPv6 sockets. To listen on IPv4 and IPv6
    # sockets, you must run two copies of vsftpd with two configuration files.
    # Make sure, that one of the listen options is commented !!
    #listen_ipv6=YES

    pam_service_name=vsftpd
    userlist_enable=YES
    tcp_wrappers=YES
    local_root=/var/www/html
    Any help would be appreciated.

  2. #2
    Just Joined!
    Join Date
    Nov 2010
    Location
    Portland, OR
    Posts
    7
    Please don't give me silence treatment. I've searched and searched and searched. Nothing work so far. I really need someones help here, I'm sure it's just something quick and easy to fix I just can't find it myself.

  3. #3
    Just Joined!
    Join Date
    Nov 2010
    Posts
    4
    have you checked the group membership on the folder you are trying to access?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Nov 2010
    Location
    Portland, OR
    Posts
    7
    Quote Originally Posted by Ali26m View Post
    have you checked the group membership on the folder you are trying to access?
    User Roman and Group user belongs to has permission to 'Create and Delete Files'.

    I've tried creating more users, and non of those work. This time it gives me:
    503 Login Incorrect
    And for sure that user exists under that name on my machine.

    I need some help, I'm lost.

  6. #5
    Just Joined!
    Join Date
    Nov 2006
    Posts
    17
    I think you're enabling userlist (userlist_enable=yes) but you're missing userlist_file.

  7. #6
    Just Joined!
    Join Date
    Nov 2010
    Location
    Portland, OR
    Posts
    7
    Quote Originally Posted by rg00 View Post
    I think you're enabling userlist (userlist_enable=yes) but you're missing userlist_file.
    List exists and needed user in there. I also cleared all users from "ftpusers" file, because it's denied users list. Still exact same error.

  8. #7
    Just Joined!
    Join Date
    Nov 2006
    Posts
    17
    I mean I can't see userlist_file directive in your conf file.

  9. #8
    Just Joined!
    Join Date
    Nov 2010
    Location
    Portland, OR
    Posts
    7
    Quote Originally Posted by rg00 View Post
    I mean I can't see userlist_file directive in your conf file.
    Oh I see, I've just added:
    userlist_file=/etc/vsftpd/user_list

    Still same error

  10. #9
    Just Joined!
    Join Date
    Nov 2006
    Posts
    17
    Did you restart the service?

  11. #10
    Just Joined!
    Join Date
    Nov 2010
    Location
    Portland, OR
    Posts
    7
    Quote Originally Posted by rg00 View Post
    Did you restart the service?
    Yes.

    Something interesting is going on that makes me think it has to do with user_list.

    Users 'Roman', and 'Capstone' are in 'user_list' file when 'vsftpd' is not.

    When trying to connect as vsftpd user, I get this:
    USER vsftpd
    Response: 331 Please specify the password.
    Command: PASS ********
    Response: 530 Login incorrect.
    Error: Critical error
    Error: Could not connect to server
    But when I'm trying to connect as Roman or Capstone I get this:
    Command: USER Roman
    Response: 530 Permission denied.
    Error: Could not connect to server
    Command: USER Capstone
    Response: 530 Permission denied.
    Error: Could not connect to server

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •