Find the answer to your Linux question:
Results 1 to 2 of 2
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Angry vsFTP and SSL from behind firewall

    setting up my vsFTP on a fedora 13 in order to be able to use a secure FTP connection from my office to my home network.

    I googled, read out vsFTP faq and followed all instructions, still not able to connect from outside my network.

    I am looking for a step by step procedure on how to setup vsFTP use ssl, this is done and when I access it with my preferred tool (filezilla), I only can connect using FTPES protocole and it works fine inside my network

    However, when I try to connect from outside the network, whatever tool I use it gets stuck. I opened ports on my firewall, tried 21 with force ssl, another config I used port 13500 TCP

    All works fine from inside when I use
    url: mylinux
    port: whatever port I coinfigure
    protocol : FTPES (FTPS doesnt work nor sFTP-SSH)
    but not when I use with whatever port, whatever protocol
    I modified my vsftp.conf as
    listen_port = 13500
    listen_address =
    If you kindly can provide me with any hin

    On my netgear firewal I authorized
    TCP port 13500 to my linux machine
    If you kindly can provide me with any hints or tips to put me in the right direction, I really would appreciate it

    So many thanks in advance

  2. #2
    Just Joined! Anspliff's Avatar
    Join Date
    Nov 2010
    Houston, Tx
    What error are you getting on the client side when you are connecting? Is there any specific out puts in /var/log/vsftpd.log in regards to this issue? Also just have to ask are you fowarding the port on your router or opening it?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts