Find the answer to your Linux question:
Results 1 to 10 of 10
Hi all, I have installed the samba in the CentOS.. But Im unable to open any folder in my windows PC. Can anyone help me in setting up the samba ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2009
    Posts
    85

    Unable to configure the samba in Centos


    Hi all, I have installed the samba in the CentOS.. But Im unable to open any folder in my windows PC. Can anyone help me in setting up the samba in my Linux Server.. I have put the smb.conf folder..

    #======================= Global Settings =====================================

    [global]
    ; load printers = yes
    cups options = raw
    server string = SambaServer
    path = /home
    workgroup = mygroup
    ; os level = 20
    hosts allow = 127. 192.
    passdb backend = tdbsam

    [root]
    path = /root/
    writeable = yes
    ; browseable = yes
    guest ok = yes

    [gupta]
    path = /home/gupta
    writeable = yes
    ; browseable = yes
    valid users = gupta, root

  2. #2
    Just Joined!
    Join Date
    May 2008
    Location
    Bangalore, India
    Posts
    24
    Were you able to login by your user id, also enable browseable=yes

    check the folder permissions.
    restart your smb server and try accessing, it should prompt for user/pass

    HTH

    -sanjeev

  3. #3
    vkv
    vkv is offline
    Just Joined!
    Join Date
    Apr 2010
    Posts
    29
    @mahesh

    I'm not that much experienced and I'm a newbie. But still I'll share what I know .

    I think it should be like this

    [gupta]
    comment = "anything"
    path = \home\gupta
    public = no
    browseable = yes
    writeable = yes
    valid_users = gupta,root

    and save this file, then check out the context of the folder whether it is samba_share_t

    then restart the service service smb restart

    this should work I think

    and still if this is not working try to make the folder as public and check

  4. #4
    Just Joined!
    Join Date
    Oct 2009
    Posts
    85
    Yes.. Im able to login with all the logins that I have.. but Im unable to access the folder in windows system.. Everytime Im getting acess denied. Even not able to login to see the folders..

  5. #5
    vkv
    vkv is offline
    Just Joined!
    Join Date
    Apr 2010
    Posts
    29
    check the permissions of the folder , do chmod a+w to that folder and restart samba service again

  6. #6
    Just Joined!
    Join Date
    Oct 2009
    Posts
    85
    Yes I did changed the permissions also. Even then I failed to login. If I see the log I get the follwoing messages all the time

    [2011/01/18 19:00:26, 0] smbd/service.c:make_connection_snum(1013)
    '/home/gupta' does not exist or permission denied when connecting to [gupta] Error was Permission denied
    [2011/01/18 19:00:26, 0] smbd/service.c:make_connection_snum(1013)
    '/home/gupta' does not exist or permission denied when connecting to [gupta] Error was Permission denied
    [2011/01/18 19:01:30, 0] smbd/service.c:make_connection_snum(1013)

  7. #7
    vkv
    vkv is offline
    Just Joined!
    Join Date
    Apr 2010
    Posts
    29
    I'm sorry
    I may need to check the issue , and then only I can go forward with the answers

  8. #8
    Just Joined!
    Join Date
    May 2008
    Posts
    9
    Quote Originally Posted by maheshgupta024 View Post
    Yes I did changed the permissions also. Even then I failed to login. If I see the log I get the follwoing messages all the time

    [2011/01/18 19:00:26, 0] smbd/service.c:make_connection_snum(1013)
    '/home/gupta' does not exist or permission denied when connecting to [gupta] Error was Permission denied
    [2011/01/18 19:00:26, 0] smbd/service.c:make_connection_snum(1013)
    '/home/gupta' does not exist or permission denied when connecting to [gupta] Error was Permission denied
    [2011/01/18 19:01:30, 0] smbd/service.c:make_connection_snum(1013)
    to witch group are you given the access permissions?
    The users must have access permissions

    regards

  9. #9
    Just Joined!
    Join Date
    May 2008
    Location
    Bangalore, India
    Posts
    24
    Check if you have selinux enabled.
    SELinux/samba - FedoraProject

    -sanjeev

  10. #10
    Just Joined!
    Join Date
    Nov 2010
    Posts
    4

    when samba auth is user

    If nothing is specified in the global section samba assumes that authentication will be user based.

    In that caseafter restarting your smb daemon you will have to issue a

    smbpasswd -a username_to_authenticate


    and follow the prompt.
    Do this for all users that need smb access.

    Cheers

    QatQat

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •