Find the answer to your Linux question:
Results 1 to 1 of 1
I have a VPS that has CentOS 5 installed, and I used to run PHP 5.3.4 on it, but some of my applications only work on PHP 5.2, so I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2011
    Posts
    1

    phpize failed when trying to install eAccelerator 0.9.6.1


    I have a VPS that has CentOS 5 installed, and I used to run PHP 5.3.4 on it, but some of my applications only work on PHP 5.2, so I was hesitating until last night when I downgraded PHP from 5.3 to 5.2.16 using Jason's PHP repository. I basically deleted (yum remove) PHP 5.3 and most of its modules that come with it, and then install PHP 5.2.16 and PHP modules. The PHP seems running okay, but I would like to reinstall PHP eAccelerator, and ran into this problem as below:

    The phpize command worked well before the downgrade, however, it gives weird error message now.

    In the eAccelerator installation folder, I run 'phpize', but got the following message:

    Code:
    configure.in:158: warning: AC_CACHE_VAL(lt_prog_compiler_pic_works, ...): suspicious cache-id, must contain _cv_ to be cached
    ../../lib/autoconf/general.m4:1974: AC_CACHE_VAL is expanded from...
    ../../lib/autoconf/general.m4:1994: AC_CACHE_CHECK is expanded from...
    aclocal.m4:3496: AC_LIBTOOL_COMPILER_OPTION is expanded from...
    aclocal.m4:7716: AC_LIBTOOL_PROG_COMPILER_PIC is expanded from...
    aclocal.m4:5549: _LT_AC_LANG_C_CONFIG is expanded from...
    aclocal.m4:5548: AC_LIBTOOL_LANG_C_CONFIG is expanded from...
    aclocal.m4:2961: AC_LIBTOOL_SETUP is expanded from...
    aclocal.m4:2941: _AC_PROG_LIBTOOL is expanded from...
    aclocal.m4:2906: AC_PROG_LIBTOOL is expanded from...
    configure.in:158: the top level
    configure.in:158: warning: AC_CACHE_VAL(lt_prog_compiler_static_works, ...): suspicious cache-id, must contain _cv_ to be cached
    aclocal.m4:3541: AC_LIBTOOL_LINKER_OPTION is expanded from...
    configure.in:158: warning: AC_CACHE_VAL(lt_prog_compiler_pic_works_CXX, ...): suspicious cache-id, must contain _cv_ to be cached
    aclocal.m4:5630: _LT_AC_LANG_CXX_CONFIG is expanded from...
    aclocal.m4:5629: AC_LIBTOOL_LANG_CXX_CONFIG is expanded from...
    aclocal.m4:4685: _LT_AC_TAGCONFIG is expanded from...
    configure.in:158: warning: AC_CACHE_VAL(lt_prog_compiler_static_works_CXX, ...): suspicious cache-id, must contain _cv_ to be cached
    configure.in:158: warning: AC_CACHE_VAL(lt_prog_compiler_pic_works_F77, ...): suspicious cache-id, must contain _cv_ to be cached
    aclocal.m4:6797: _LT_AC_LANG_F77_CONFIG is expanded from...
    aclocal.m4:6796: AC_LIBTOOL_LANG_F77_CONFIG is expanded from...
    configure.in:158: warning: AC_CACHE_VAL(lt_prog_compiler_static_works_F77, ...): suspicious cache-id, must contain _cv_ to be cached
    configure.in:158: warning: AC_CACHE_VAL(lt_prog_compiler_pic_works_GCJ, ...): suspicious cache-id, must contain _cv_ to be cached
    aclocal.m4:6899: _LT_AC_LANG_GCJ_CONFIG is expanded from...
    aclocal.m4:6898: AC_LIBTOOL_LANG_GCJ_CONFIG is expanded from...
    configure.in:158: warning: AC_CACHE_VAL(lt_prog_compiler_static_works_GCJ, ...): suspicious cache-id, must contain _cv_ to be cached
    configure.in:158: warning: AC_CACHE_VAL(lt_prog_compiler_pic_works, ...): suspicious cache-id, must contain _cv_ to be cached
    ../../lib/autoconf/general.m4:1974: AC_CACHE_VAL is expanded from...
    ../../lib/autoconf/general.m4:1994: AC_CACHE_CHECK is expanded from...
    aclocal.m4:3496: AC_LIBTOOL_COMPILER_OPTION is expanded from...
    aclocal.m4:7716: AC_LIBTOOL_PROG_COMPILER_PIC is expanded from...
    aclocal.m4:5549: _LT_AC_LANG_C_CONFIG is expanded from...
    aclocal.m4:5548: AC_LIBTOOL_LANG_C_CONFIG is expanded from...
    aclocal.m4:2961: AC_LIBTOOL_SETUP is expanded from...
    aclocal.m4:2941: _AC_PROG_LIBTOOL is expanded from...
    aclocal.m4:2906: AC_PROG_LIBTOOL is expanded from...
    configure.in:158: the top level
    configure.in:158: warning: AC_CACHE_VAL(lt_prog_compiler_static_works, ...): suspicious cache-id, must contain _cv_ to be cached
    aclocal.m4:3541: AC_LIBTOOL_LINKER_OPTION is expanded from...
    phpize gives this similar error not only to eAccelerator, but also to fffmpeg-php, I guess this must be due to the same error source. anyone knows what goes wrong with my box? thanks!
    Last edited by RCholic; 01-22-2011 at 12:28 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •