Find the answer to your Linux question:
Results 1 to 2 of 2
I tried to create a root file system.For this i was trying to cp libraries to a directory and strip the symbloic links for debug strip --strip-debug lib.so.6 when I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2003
    Posts
    3

    Linux crashed due to error in loading shared libraries


    I tried to create a root file system.For this i was
    trying to cp libraries to a directory and strip the
    symbloic links for debug
    strip --strip-debug lib.so.6
    when I gave this command the terminal window
    closed.along with this other terminal windows closed
    when i gave any commands.

    I tried to reboot but failed with this error at the
    boot time in INIT runlevel:

    init: error while loading shared libraries: lib.so.6:
    cannot load shared
    object.
    so finally my system is crashed.

    pls can you kindly help me how to boot linux again.

    regards,
    karan

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Fetch a copy of libc from a working system or internet or something and get it back there using rescue mode or whatever is appropriate for your distribution.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •