Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 16 of 16
Originally Posted by markwaugh Still i don't understand quite a few things. Can you please explian in detail (step-by-step) ? I have the correct permission in the righ directory. what ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Engineer jledhead's Avatar
    Join Date
    Oct 2004
    Location
    North Carolina
    Posts
    1,077

    Quote Originally Posted by markwaugh
    Still i don't understand quite a few things. Can you please explian in detail (step-by-step) ? I have the correct permission in the righ directory. what next ? Thanks for ur help.
    it doesn't sound like it. is your apache user the owner of these files?


    make sure for cgi that you chmod +x the files

  2. #12
    Linux Enthusiast
    Join Date
    Jun 2002
    Location
    San Antonio
    Posts
    621
    Since you are the administrator, you get to see the actual error logs. Look at them. Maybe tell us what they say, hey?

    This means that seeing what the error log says when you try to access the script would help.

    Best,

    Samuel
    I respectfully decline the invitation to join your delusion.

  3. #13
    Just Joined!
    Join Date
    Sep 2004
    Location
    Sydney, Australia
    Posts
    42
    This is the error_log when trying to access http://localhost/index.php

    [Tue Nov 30 09:34:35 2004] [error] [client 10.10.16.18] client denied by server configuration: /usr/local/apache/cgi-bin/php

    This is what i have in /srv/www/htdocs
    -rw-r--r-- 1 root root 17 Nov 25 14:43 index.php

    <?
    phpinfo();
    ?>


    /etc/apache2
    -rw-r--r-- 1 root root 8.8K Nov 29 12:08 httpd.conf

    I just want to execute a simple php script, that's it. Please advise and thanks in advance.

  4. $spacer_open
    $spacer_close
  5. #14
    Linux Engineer jledhead's Avatar
    Join Date
    Oct 2004
    Location
    North Carolina
    Posts
    1,077
    it might be just as easy to recompile php instead of running it as cgi

    this is how I installed apache and php
    http://www.linuxforums.org/forum/top...tml&highlight=

    # ./configure –with-mysql –with-apxs2=/usr/local/apache2/bin/apxs

  6. #15
    Just Joined!
    Join Date
    Sep 2004
    Location
    Sydney, Australia
    Posts
    42
    I tried exactly what you said in the previous forum, but i get an error if run this in /home/mydir/httpd-2.0.52.

    ./configure –prefix=/usr/local/apache2 –enable-mods-shared=all
    configure: error: invalid variable name: –-enable-mods-shared

    I have downloaded the lastest version of apache and php. i tried with ./configure and make, make install, still no luck, php file is trying to download. Please advise.

  7. #16
    Linux Engineer jledhead's Avatar
    Join Date
    Oct 2004
    Location
    North Carolina
    Posts
    1,077
    Quote Originally Posted by markwaugh
    I tried exactly what you said in the previous forum, but i get an error if run this in /home/mydir/httpd-2.0.52.

    ./configure –prefix=/usr/local/apache2 –enable-mods-shared=all
    configure: error: invalid variable name: –-enable-mods-shared

    I have downloaded the lastest version of apache and php. i tried with ./configure and make, make install, still no luck, php file is trying to download. Please advise.
    thats strange then, I have compiled this countless times on a redhat 9 and others machines.

    is this what you are downloading
    http://www.theshell.com/pub/apache/h...-2.0.52.tar.gz

    then tar zxvf httpd-2.0.52.tar.gz

    just to make sure, edit (vi or whatever) the configure file and search for mods, then enable-mods-shared should be first one it finds

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •