Find the answer to your Linux question:
Results 1 to 4 of 4
Ok So I have been using Webmin to set up samba on my Centos 5.5 machine (Domain name in Samba is KISKA). I set up a test directory /smbtest on ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2011
    Posts
    2

    Fighting with samba


    Ok So I have been using Webmin to set up samba on my Centos 5.5 machine (Domain name in Samba is KISKA).

    I set up a test directory /smbtest on the machine and made a share on webmin.

    My problem is that when I try to connect to the share on my windows machine (im running windows 7) it gives me a message saying this:

    Code:
    Windows Cannot Access \\Kiska\smbtest
    I have made sure to make the permissions on /smbtest 777 and I have tried alot of other stuff as well.

    Here is my Smb.conf

    Code:
    [global]
    	load printers = yes
    	cups options = raw
    	netbios name = KISKA
    	winbind enum users = no
    	default = global
    	workgroup = NUS
    	os level = 20
    	winbind enum groups = no
    	null passwords = yes
    	winbind enable local accounts = no
    	winbind trusted domains only = yes
    	security = share
    	preferred master = no
    	passdb backend = tdbsam
    
    [SMBTEST]
    	writeable = yes
    	delete readonly = yes
    	path = /smbtest
    	force directory mode = 777
    	force create mode = 777
    	public = yes
    	create mode = 777
    	directory mode = 777
    Thanks for any help you can give!!!

  2. #2
    Linux Newbie Nagarjuna's Avatar
    Join Date
    Feb 2011
    Posts
    122
    Hey, Kronik.

    Just to clarify, have you added your Samba user on the Linux box yet? If you haven't, first make sure the Linux user exists, and then add it to the Samba user database:

    Code:
    useradd <user>
    passwd <user>
    smbpasswd -a <user>
    You may also want to set the SMBTEST share to be browsable.

    Code:
    [SMBTEST]
    writeable = yes
    delete readonly = yes
    path = /smbtest
    force directory mode = 777
    force create mode = 777
    public = yes
    create mode = 777
    directory mode = 777
    browsable = yes
    I'm no Samba master, but this is my two cents. I hope it helps.
    Last edited by Nagarjuna; 03-26-2011 at 05:04 AM.

  3. #3
    Just Joined!
    Join Date
    Mar 2011
    Posts
    2
    Well I used webmin to convert my unix user and group into a samba user and group. I tried adding browsable = yes

    NOW I HAVE A NEW PROBLEM

    When I try and open the share it pops up asking for a username and password. I have tried using my samba username and password, my unix usernames and passwords, and my windows usernames and passwords and NONE of them work.

    Here is my current config file:

    Code:
    [global]
    	load printers = yes
    	cups options = raw
    	netbios name = KISKA
    	winbind enum users = no
    	default = global
    	workgroup = NUS
    	os level = 20
    	winbind enum groups = no
    	null passwords = yes
    	winbind enable local accounts = no
    	winbind trusted domains only = yes
    	security = share
    	preferred master = no
    	passdb backend = tdbsam
    
    [SMBTEST]
    	delete readonly = yes
    	writeable = yes
    	path = /smbtest
    	force directory mode = 777
    	force create mode = 777
    	valid users = Staff,Admin,Daniel,Tech,@staff
    	public = yes
    	create mode = 777
    	directory mode = 777
            browsable = yes
    Thanks for your help

  4. #4
    Linux Newbie Nagarjuna's Avatar
    Join Date
    Feb 2011
    Posts
    122
    One thing you can try doing is double checking that the usernames in the 'valid users' option, match the usernames of the Linux users. So, when you login into your share from Windows, you will log in with the Linux user which you referenced in the valid users option, and also configured with smbpasswd.

    Maybe try adding the Linux user to the valid options parameter. I believe it to be case-sensitive so if the username is all lowercase, make it that is typed in so. Something like this:

    Code:
    [SMBTEST]
    delete readonly = yes
    writeable = yes
    path = /smbtest
    force directory mode = 777
    force create mode = 777
    valid users = daniel
    public = yes
    create mode = 777
    directory mode = 777
    browsable = yes
    I plugged the above share into my smb.conf file with my Linux username added to the valid users option and I am able to access it from a Windows XP system on the network.

    Again, I'm no Samba wiz, but it's something to try. This article addresses it in more detail: Samba: Users, Security, and Domains.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •