Find the answer to your Linux question:
Results 1 to 4 of 4
I am using Fedora Core linux for the operating system and Postfix as my mail server. Users that have email addresses with Comcast or AOL do not get any mail ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2007
    Posts
    17

    Post Fix Help


    I am using Fedora Core linux for the operating system and Postfix as my mail server. Users that have email addresses with Comcast or AOL do not get any mail that is sent from my mail server but all other do, like those with Yahoo or personal domains. I have contacted Comcast and they verified that my IP is not blocked. I tried to look at my mail logs and they are blank. Has anyone run into this issue and is there a fix?

  2. #2
    Just Joined!
    Join Date
    Aug 2007
    Location
    Silicon Valley
    Posts
    2

    Email sending problems

    Before getting into anything PostFix specific, I'd recommend that you try manually sending a test email by Telnet MailServer 25, and go through the basic sequence:
    HELO yourdomain.com
    MAIL FROM: <youremail@yourdomain.com>
    rcpt to:<recipient@theirdomain.com>
    data
    This is only a test, please don't respond
    .
    quit


    Be careful to NOT use the backspace key - it will not work.
    Better to type the test script in an editor window and copy/paste it to the telnet session.

    The key idea being to actually SEE what the mail server's response is. If that doesn't work, or if you get a response that doesn't help, then write back.

    Good luck,

    Bob

  3. #3
    Just Joined!
    Join Date
    May 2007
    Posts
    17
    Before I read your replay I went back to Sendmail, Same Issue, Users with Comacast emais and AOL are not receiving the mail I know the server is working beacuse I CC myself and I get the messages. So its not the MTA. Any other suggestions?

  4. #4
    Just Joined!
    Join Date
    Aug 2007
    Location
    Silicon Valley
    Posts
    2
    Did you try it in a manual SMTP session? If so, what was the response from the mail server(s)?

    I just tried it with aol.com and got the following:
    220-mtain-mj01.r1000.mx.aol.com ESMTP Internet Inbound
    220-AOL and its affiliated companies do not
    220-authorize the use of its proprietary computers and computer
    220-networks to accept, transmit, or distribute unsolicited bulk
    220-e-mail sent from the internet.
    220-Effective immediately:
    220-AOL may no longer accept connections from IP addresses
    220 which no do not have reverse-DNS (PTR records) assigned.

    Which begs the question: Does your IP address have a reverse DNS lookup which includes your own domain name?

    This is why I suggested that you do the test process manually, not using Postfix or Sendmail. Alternately, you could sniff the connection attempt and read the response in the Wireshark/Ethereal capture.

    Bob

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •