Find the answer to your Linux question:
Results 1 to 10 of 10
I'm just trying to set up a simple file server on my OpenIndiana box, but no matter what tutorial or smb.conf setting I seem to try I get the same ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2007
    Posts
    7

    Unhappy Samba won't authenticate users


    I'm just trying to set up a simple file server on my OpenIndiana box, but no matter what tutorial or smb.conf setting I seem to try I get the same problem.

    First, my latest smb.conf:
    Code:
    [global]
    	netbios name = CASPER
    	workgroup = LAN
    	server string = File Server
    	log file = /var/samba/log/smbd.log
    	max log size = 100
    	encrypt passwords = yes
    	smb passwd file = /etc/samba/smbpasswd
    	security = share
    	unix password sync = Yes
    	passwd program = /usr/bin/passwd %u
    	passwd chat = *New*UNIX*password* %n\n *ReType*new*UNIX*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*	
    	socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192	
    
    [media]
    	comment = Media Files
    	path = /share/media
    	public = yes
    	read only = no
    		
    [sam]
    	comment = Sams Files
    	path = /share/userfiles/sam
    	valid users = sam
    	public = no
    	writable = yes
    	printable = no
    I also made sure to add both the unix user and smb user to the server. I have the same user name "sam" on my windows desktop, and ubuntu laptop, and I used the same password. Ive tested the accounts and they seem to work fine. I can login to the unix account and samba shows that it has a user named sam

    The problem:
    The server and shares show up just fine, and the media share is readable (not writable but that most likely just a permission thing and not the issue at hand). The problem is with the private share "sam", heres what happens:

    Local Test:
    Code:
    sam(at)casper:~$ /usr/bin/smbclient //192.168.0.1/sam
    Enter sam's password:
    Connection to 192.168.0.1 failed (Error NT_STATUS_CONNECTION_REFUSED)
    From my Ubuntu laptop:
    sam(at)osaka:~$ smbclient //192.168.1.13/sam
    Enter sam's password:
    session setup failed: NT_STATUS_LOGON-FAILURE
    And from my Windows Vista desktop I just get a login unsuccessful message.

    My /var/samba/log/smbd.log is filled with these:
    Code:
    [2011/05/07 13:46:32.075667,  1] smbd/service.c:677(make_connection_snum)
      create_connection_server_info failed: NT_STATUS_WRONG_PASSWORD
    [2011/05/07 13:46:32.079670,  1] smbd/service.c:677(make_connection_snum)
      create_connection_server_info failed: NT_STATUS_WRONG_PASSWORD
    [2011/05/07 13:46:32.086242,  1] smbd/service.c:677(make_connection_snum)
      create_connection_server_info failed: NT_STATUS_WRONG_PASSWORD
    and yes, I triple checked all the passwords.


    From my tests it seems that samba refuses to use any sort of user other then the guest account.

    I tried it with "security = user" but run into the same issue, just when I connect to the server instead of the share, so it efectivlly blocks me from the media share as well.

    Im probably missing something simple thats preventing the authentication, anyone care to point it out?

    Thank you

  2. #2
    Just Joined!
    Join Date
    Dec 2007
    Posts
    7
    Ive tried all I can think of, is there any other test I could run to gather more information on this?

  3. #3
    Just Joined!
    Join Date
    Dec 2007
    Posts
    7
    Does anyone have any idea what other files or programs are used in the process?

    That way I can go though them one by one and check them out.

  4. #4
    Just Joined!
    Join Date
    Dec 2007
    Posts
    7
    Ok, this is weird. This is only one of three forums I posted this to and I have yet to get a reply from anyone. Does no one use Samba? should I be looking at something else?

    I know this is possible since thats the whole point of samba authentication, and Ive followed the examples to the letter. What the hell is going on with this thing?

  5. #5
    Linux Guru
    Join Date
    Nov 2007
    Posts
    1,754
    Nope, no one uses Samba.

    This is a Linux forum. You have an authentication error on a non-Linux platform and are asking "what other files are used." Why would a Linux forum be a good place to ask about Samba on Solaris?

  6. #6
    Just Joined!
    Join Date
    Dec 2007
    Posts
    7
    Quote Originally Posted by HROAdmin26 View Post
    Nope, no one uses Samba.

    This is a Linux forum. You have an authentication error on a non-Linux platform and are asking "what other files are used." Why would a Linux forum be a good place to ask about Samba on Solaris?
    Because Solaris is similar enough that Linux know how works pretty damn good.
    This forum has been an awesome resource in the past.
    Do you know of a better forum to ask?

    If this were a Linux box, where would I start looking?

  7. #7
    Linux Guru
    Join Date
    Nov 2007
    Posts
    1,754
    You would be wrong. I looked at Samba in OI - it's not close to similar. *From what I gathered* there is a native CIFS server that comes from the Samba code, but is changed for integration with OI. I saw other people that have done native compiles of Samba source on OI - these have the same binaries/names as most other platforms.

    There seems to be an smbadm command on OI, there is no smb.conf (or even an /etc/samba dir), no smbpasswd command, and service management is done via SMF. I don't see much similarity in starting, stopping, or managing the CIFS server in OI.

    In fact, when I Google "openindiana cifs" I get this Wiki, which only mentions using ZFS commands:

    CIFS / SMB

    To share a zfs file system named "bob" via smb/cifs execute a command like the following below. Note that the share name is arbitrary and can be completely different than the name of the file system itself, as seen in the example below.

    $ zfs set sharesmb=name=myshare yourpool/shares/bob

    You can set some text description (Windows Explorer shows this text) for the share using this:

    $ zfs set "sharesmb=name=myshare,description=My ZFS share" yourpool/shares/bob

    To just turn on cifs sharing for a zfs file system without specifying a share name execute a command like the following. Note that the auto-generated names created using this method are usually not user-friendly.

    $ zfs set sharesmb=on yourpool/shares/bob

    Check your work or check current status with:

    $ zfs get sharesmb yourpool/shares/bob

    You may need to enable "pam_smb_passwd" to make regular OpenIndiana users have smb passwords. To do so, add the following line to the end of the file "/etc/pam.conf":

    other password required pam_smb_passwd.so.1 nowarn

    And then change the user's password with the "passwd" command. After this, their smb password will also be set so they can connect via smb with the same username and password.
    Since OI installs on ZFS by default, have you done the steps above?

  8. #8
    Just Joined!
    Join Date
    Dec 2007
    Posts
    7
    Thank you, I did not think to look into CIFS directly, I ill give that a shot.

    Weird thing is that I installed the Samba packages off of the OI repo, and I do get a smb.conf, and a /etc/samba/ directory and everything works perfectly as expected, except for the authentication.

  9. #9
    Just Joined!
    Join Date
    May 2009
    Posts
    6

    Regarding samuser login

    Hi,

    It seems your issue related your samba role is PDC.
    if role domain pdc please deactivate pdc and login . if you still facing issue please run this command and paste the output here, so i can help you further.

    Please run this command and paste the out put here.
    1. testparm

  10. #10
    Just Joined!
    Join Date
    May 2009
    Posts
    6

    Regarding samuser login

    Hi,

    Please check with this command format and if you still facing any issue please run the below command and paste the output here.
    1.testparm

    >am(at)casper:~$ /usr/bin/smbclient //192.168.0.1/sam:
    Enter sam's password:
    Connection to 192.168.0.1 failed (Error NT_STATUS_CONNECTION_REFUSED)


    smbclient //192.168.0.1/windows-share-folder-name -U user

    Regards.
    Balaa

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •