Find the answer to your Linux question:
Results 1 to 1 of 1
Please be kind, it has been a frustrating time trying to solve this. I have considerable delay on address resolution. I have opensuse 11.2 for my internal DNS server. Bind ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! Kumado's Avatar
    Join Date
    Jul 2006
    Posts
    81

    Bind with unresolved EDNS issues


    Please be kind, it has been a frustrating time trying to solve this.

    I have considerable delay on address resolution.

    I have opensuse 11.2 for my internal DNS server.
    Bind 9.61P3-1.3.1
    I get the error message " network unreachable resolving 'testats.inuvo.com/A/IN': 2001:500:2f::f#53 "

    I have read a lot of Google searched sites that tell me I am not alone.
    I have read that you should just disable the logging of the error - ?????? I want it fixed!
    I have added the options=-4 to my /etc/sysconfig/named file - it must ignore that, I know it is the correct file since I can type " hello" , save and restart and it does not recognize hello as a command.

    In the named file NAMED_ARGS is there. it does not show what it is used for directly but out of desperation, I put the -4 in it's quotes. I no longer see the network unreachable resolving in the log but I do see success resolving 'ccccc.com/A' (in '.'?) after disabling EDNS in the log so did it just disable the error being logged?

    I added the option edns-udp-size 512; to humor things.

    I did the tests to see if my firewall can handle EDNS packets, it passes.

    I also ran from prompt: named -u named -c /etc/named.conf -4
    It continues as before.

    How can I disable EDNS permanently? ( at least till it is more of a used option )

    I can see from Google searches this is a long time problem.

    Let em also ask, network unreachable resolving , my NAT has no rules for IPV6, even if I did, the core switch from our ISP does not have an IPV6 gateway address nor does our ISP. Is it unreachable because of that? I wonder if I fully understand the error.

    Still, it will resolve and work with IPV4 so why do I need IPV6?

    thanks

    kumado
    Last edited by Kumado; 05-10-2011 at 06:31 PM. Reason: additional info

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •