Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 13 of 13
Like Tree1Likes
Originally Posted by atreyu Have you put anything in your tcp_wrappers config files, /etc/hosts.allow and /etc/hosts.deny? I don't know why that would be a problem, but it is one of ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Aug 2011
    Posts
    13

    Quote Originally Posted by atreyu View Post
    Have you put anything in your tcp_wrappers config files, /etc/hosts.allow and /etc/hosts.deny? I don't know why that would be a problem, but it is one of the last things listed in your strace output.

    Also, is there ANY output when you run /usr/sbin/vsftpd by itself?

    EDIT: Is anything else already listening on the default FTP port (21)?
    Code:
    netstat -tulnp|grep :21
    No I haven't put anything in these files.

    When I run /usr/sbin/vsftpd there is no out put.

    The out put of netstat -tulnp|grep :21 is:
    tcp 0 0 0.0.0.0:21 0.0.0.0:* LISTEN 4463/xinetd

    Thanks

  2. #12
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    So some other xinetd-controlled process is running and listening on port 21, I think that would cause vsftpd to fail to start.

    As a quick test, try this to see if that is it:
    Code:
    service xinetd stop
    Then make sure nothing is listening on that port:
    Code:
    netstat -tulnp|grep :21
    Then fire up vsftpd:
    Code:
    service vsftpd start
    Run the netstat command again and see if it is listening.

    If that is it, then the culprit is probably gssftp (kerberized FTP server). You can see if it is enabled with:
    Code:
    chkconfig --list gssftp
    If it is on, disable it with:
    Code:
    chkconfig gssftp off
    FYI, netstat lists xinetd b/c xinetd is a master daemon that controls various network-related sub-daemons. Look in /etc/xinetd.d/ to see them all. Files in there are xinetd services and any file with disable = no is enabled and will be run when xinetd is started.
    titley100 likes this.

  3. #13
    Just Joined!
    Join Date
    Aug 2011
    Posts
    13
    Quote Originally Posted by atreyu View Post
    So some other xinetd-controlled process is running and listening on port 21, I think that would cause vsftpd to fail to start.

    As a quick test, try this to see if that is it:
    Code:
    service xinetd stop
    Then make sure nothing is listening on that port:
    Code:
    netstat -tulnp|grep :21
    Then fire up vsftpd:
    Code:
    service vsftpd start
    Run the netstat command again and see if it is listening.

    If that is it, then the culprit is probably gssftp (kerberized FTP server). You can see if it is enabled with:
    Code:
    chkconfig --list gssftp
    If it is on, disable it with:
    Code:
    chkconfig gssftp off
    FYI, netstat lists xinetd b/c xinetd is a master daemon that controls various network-related sub-daemons. Look in /etc/xinetd.d/ to see them all. Files in there are xinetd services and any file with disable = no is enabled and will be run when xinetd is started.
    Thank you so much mate it's working now. Many thanks !!!

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •