Find the answer to your Linux question:
Results 1 to 6 of 6
hello everyone I am running SQUID-3.1.9 on my debian linux system, everytime when make a GET request for any sites TCP_MISS is logged in access.log. access log has fallowing data ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2011
    Posts
    3

    always TCP_MISS in access.log


    hello everyone

    I am running SQUID-3.1.9 on my debian linux system, everytime when make a GET request for any sites TCP_MISS is logged in access.log. access log has fallowing data logged into it.

    1314092367.253 571 192.168.0.1 TCP_MISS/304 216 GET XXX - DIRECT/74.125.236.35

    I think data is not being cached. how do I make squid cache data. and when I request 2nd time same site it should return TCP_HIT i.e it should be from cache..?

    Thanks for help

  2. #2
    Just Joined!
    Join Date
    Aug 2011
    Location
    London, UK
    Posts
    19
    Have you made (m)any changes to the default config?

  3. #3
    Just Joined!
    Join Date
    Aug 2011
    Posts
    3
    yes. my squid.conf is as follows

    #
    # Recommended minimum configuration:
    #
    acl manager proto cache_object COAP
    acl localhost src 127.0.0.1/32 ::1
    acl to_localhost dst 127.0.0.0/8 0.0.0.0/32 ::1

    # Example rule allowing access from your local networks.
    # Adapt to list your (internal) IP networks from where browsing
    # should be allowed
    acl localnet src 10.0.0.0/8 # RFC1918 possible internal network
    acl localnet src 172.16.0.0/12 # RFC1918 possible internal network
    acl localnet src 192.168.0.0/16 # RFC1918 possible internal network
    acl localnet src fc00::/7 # RFC 4193 local private network range
    acl localnet src fe80::/10 # RFC 4291 link-local (directly plugged) machines

    acl SSL_ports port 443
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 # https
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl CONNECT method CONNECT

    #
    # Recommended minimum Access Permission configuration:
    #
    # Only allow cachemgr access from localhost
    http_access allow manager localhost
    http_access deny manager

    # Deny requests to certain unsafe ports
    http_access deny !Safe_ports

    # Deny CONNECT to other than secure SSL ports
    http_access deny CONNECT !SSL_ports

    # We strongly recommend the following be uncommented to protect innocent
    # web applications running on the proxy server who think the only
    # one who can access services on "localhost" is a local user
    http_access deny to_localhost

    #
    # INSERT YOUR OWN RULE(S) HERE TO ALLOW ACCESS FROM YOUR CLIENTS
    # Example rule allowing access from your local networks.
    # Adapt localnet in the ACL section to list your (internal) IP networks
    # from where browsing should be allowed
    acl blocksites url_regex -i .facebook.com .google.com
    http_access allow blocksites
    http_access allow localnet
    http_access allow localhost
    http_access deny all
    cache_mgr parashuram.l@accord-soft.com
    visible_hostname myproxy
    cache_mem 8 MB
    # And finally deny all other access to this proxy

    # Squid normally listens to port 3128
    http_port 3128 transparent


    # We recommend you to use at least the following line.
    hierarchy_stoplist cgi-bin ?

    # Uncomment and adjust the following to add a disk cache directory.
    cache_dir ufs /usr/local/squid/var/cache 1024 16 256

    # Leave coredumps in the first cache dir
    coredump_dir /usr/local/squid/var/cache

    # Add any of your own refresh_pattern entries above these.
    refresh_pattern ^ftp: 1440 20% 10080
    refresh_pattern ^gopher: 1440 0% 1440
    #refresh_pattern -i (/cgi-bin/|\?) 0 0% 0
    refresh_pattern . 0 20% 4320

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Aug 2011
    Location
    London, UK
    Posts
    19
    Double check that the cache_dir exists and that it has appropriate permissions for squid to write to it. And test with a static site.

  6. #5
    Just Joined!
    Join Date
    May 2011
    Location
    Malaysia
    Posts
    39
    Hi,

    If you've fixed this then good for you but if you havent, assuming you have your cache_dir all sorted out, I would suggest setting/checking your refresh_pattern.
    Works wonder with couple squids we have running.

  7. #6
    Just Joined!
    Join Date
    Aug 2011
    Posts
    3
    I have fixed it, now its caching and returning TCP_MEM_HIT very happy
    Thanks everyone for good suggestion

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •