Hi,

I can't write (at) on this forum, so all (a) bellow means (at).

I have problem with distribution emails, I need email from domain (a)cokdeje.cz send to user forexample info, from domain (a)surfujeme.cz to another, etc.


/etc/postfix/main.cf

Code:
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no
append_dot_mydomain = no
readme_directory = no
smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls=yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
mydomain = surfujeme.cz
myhostname = mail.surfujeme.cz
alias_maps = hash:/etc/aliases
virtual_alias_maps = hash:/etc/postfix/virtual
alias_database = hash:/etc/aliases
virtual_alias_domains = /etc/postfix/domains
mydestination = $myhostname localhost /etc/postfix/domains
relayhost = 
relay_domains = $mydestination
mailbox_size_limit = 0
recipient_delimiter = 
inet_interfaces = all
myorigin = $mydomain
default_transport = smtp
relay_transport = smtp
inet_protocols = all
home_mailbox = Maildir/

My virtual users:
/etc/postfix/virtual

Code:
webcreating.cz  DOMAIN
(a)webcreating.cz     info

surfujeme.cz    DOMAIN
(a)surfujeme.cz       info

frosty22.cz DOMAIN
(a)frosty22.cz        info

e-lekce.cz  DOMAIN
(a)e-lekce.cz     elekcecz

cokdeje.cz  DOMAIN
(a)cokdeje.cz     cokdejecz

zujimode.cz DOMAIN
(a)zujimode.cz        zujimodecz

And /etc/postfix/domains

Code:
zujimode.cz
surfujeme.cz
cokdeje.cz
frosty22.cz
e-lekce.cz

When send email to some domain:

Code:
anything(a)surfujeme.cz
anything(a)zujimode.cz
anything(a)cokdeje.cz

Postfix ignore domainname and use domain from main.cf => setting myorigin which is from mydomain and in virtual file find correct user info, so all emails are stored by user info.

How I repair it? I don't need ignore domain name ;(
I try it for 1 week, still nothing.