Find the answer to your Linux question:
Results 1 to 4 of 4
I've followed a few youtube videos and written tutorials on the subject but I must be doing something wrong in the configurations because after I activate both servers, renew ip ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2011
    Posts
    2

    DNS and DHCP problem


    I've followed a few youtube videos and written tutorials on the subject but I must be doing something wrong in the configurations because after I activate both servers, renew ip on another computer on the same network, I cannot access webpages anymore. I get an error message that there is an error with DNS. Strangely enough, google domains work fine, just a bit slow.

    Is there any way to troubleshoot and see exactly where the problem is? Both servers show as running normally.

    I am using CentOS version 5.6, and activating both servers through webmin.

    Admittedly I am rather new to setting up servers and linux in general, but would appreciate any help.
    Thanks.

  2. #2
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,677
    What is your output from the following commands:

    Code:
    ifconfig
    cat /etc/resolve.conf

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

  3. #3
    Just Joined!
    Join Date
    Sep 2011
    Posts
    2
    I am pasting the results of your commands below.
    Please note I have no resolve.conf, but there is a resolv.conf

    Code:
    [root@linux ~]# ifconfig
    eth0      Link encap:Ethernet  HWaddr 00:12:3F:72:85:A4  
              inet addr:192.168.1.3  Bcast:192.168.1.255  Mask:255.255.255.0
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:9382 errors:0 dropped:0 overruns:0 frame:0
              TX packets:6860 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:6022898 (5.7 MiB)  TX bytes:1451631 (1.3 MiB)
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:8638 errors:0 dropped:0 overruns:0 frame:0
              TX packets:8638 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:9757857 (9.3 MiB)  TX bytes:9757857 (9.3 MiB)
    
    peth0     Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF  
              UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
              RX packets:9401 errors:0 dropped:0 overruns:0 frame:0
              TX packets:7001 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:6025362 (5.7 MiB)  TX bytes:1465794 (1.3 MiB)
    
    vif0.0    Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF  
              UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
              RX packets:6860 errors:0 dropped:0 overruns:0 frame:0
              TX packets:9382 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:1451631 (1.3 MiB)  TX bytes:6022898 (5.7 MiB)
    
    virbr0    Link encap:Ethernet  HWaddr 00:00:00:00:00:00  
              inet addr:192.168.122.1  Bcast:192.168.122.255  Mask:255.255.255.0
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:67 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:0 (0.0 b)  TX bytes:11844 (11.5 KiB)
    
    xenbr0    Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF  
              UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
              RX packets:2964 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:870254 (849.8 KiB)  TX bytes:0 (0.0 b)
    
    [root@linux ~]# cat /etc/resolve.conf
    cat: /etc/resolve.conf: No such file or directory
    [root@linux ~]# cat /etc/resolv.conf
    search linux
    nameserver 127.0.0.1
    [root@linux ~]#

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,677
    Ah, sorry about the typo resolve.conf instead of resolv.conf. Glad you figured this out.

    Do you have a DNS server running on your system?
    You need to have some DNS servers setup in your resolv.conf file. That is how the system knows where to send DNS queries.
    Look in your DHCP configuration for
    Code:
    option domain-name-servers
    and ensure you have your DNS servers set there.

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •