Find the answer to your Linux question:
Results 1 to 3 of 3
Linux 2.6.18-194.17.1.el5 on x86_64 Postfix version 2.3.3 Our postfix email server was working great until our servers were physically moved from one data center to another. After the move, our ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2010
    Posts
    2

    postfix: User unknown in local recipient table


    Linux 2.6.18-194.17.1.el5 on x86_64
    Postfix version 2.3.3

    Our postfix email server was working great until our servers were physically moved from one data center to another.
    After the move, our Java email application throws a javax.mail.AuthenticationFailedException when attempting to sign in to the server and send email.
    The postifx configuration looks okay to me, though a contractor set up server and I don't know anything about postfix other than what I've learned from troubleshooting this problem.

    main.cf is included below.

    I reconfigured the applications to use my user account and was able to log on to the email server so I believe the email server itself is
    working correctly, other than this problem.

    From a terminal, I can telnet in to localhost and successfully send an email to testacct:

    Code:
    # telnet localhost smtp
    # ehlo localhost
    # mail from:myaccount
    # rcpt to:testacct
    250 2.1.5 Ok
    However, if I telnet into our email server domain I get a different result:

    Code:
    # telnet mail.domain.com smtp
    # ehlo domain
    # mail from:myaccount
    # rcpt to:testacct
    550 5.1.1 <testacct>: Recipient address rejected: User unknown in local recipient table
    # rcpt to:anotheraccount
    250 2.1.5 Ok
    How do I add a Linux account to the local recipient table?
    I googled the 550 error and found various posts about /etc/aliases.
    testacct is not listed in that file, so I added it and reloaded the server but that did not fix it.
    I attempted to create a new user (from Webmin) and that user did not work either.

    Here is main.cf. I tried uncommenting each local_recipient_maps parm one at a time but still no workie.
    All three were commented out in the original configuration.

    Code:
    queue_directory = /var/spool/postfix
    command_directory = /usr/sbin
    daemon_directory = /usr/libexec/postfix
    mail_owner = postfix
    inet_interfaces = all
    mydestination = hash:/etc/postfix/mydomains
    #local_recipient_maps = unix:passwd.byname $alias_maps
    #local_recipient_maps = proxy:unix:passwd.byname $alias_maps
    #local_recipient_maps =
    unknown_local_recipient_reject_code = 550
    mynetworks = xxx.xxx.xxx.244/32, 127.0.0.0/8
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    home_mailbox = Maildir/
    smtpd_banner = $myhostname ESMTP $mail_name
    debug_peer_level = 2
    debugger_command =
    	 PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
    	 xxgdb $daemon_directory/$process_name $process_id & sleep 5
    sendmail_path = /usr/sbin/sendmail.postfix
    newaliases_path = /usr/bin/newaliases.postfix
    mailq_path = /usr/bin/mailq.postfix
    setgid_group = postdrop
    html_directory = no
    manpage_directory = /usr/share/man
    sample_directory = /usr/share/doc/postfix-2.3.3/samples
    readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES
    virtual_alias_maps = hash:/etc/postfix/virtual
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    smtpd_sasl_local_domain = $myhostname
    smtp_sasl_security_options = noplaintext
    smtpd_recipient_restrictions = permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination
    mailbox_size_limit = 256000000

  2. #2
    Linux Newbie hans51's Avatar
    Join Date
    May 2011
    Posts
    136
    I am no expert in postfix, but had same error for some system recipients in my log file for both my 2 mail servers
    and solved it as below:

    I have my alias list in the postfix file
    /etc/postfix/aliases

    that file contains the reminder:

    # >>>>>>>>>> The program "newaliases" will need to be run
    # >> NOTE >> after this file is updated for any changes
    # >>>>>>>>>> to show through to sendmail.

    also if you change any of the postfix files like below example (and other files having a db)
    /etc/postfix/virtual
    you have to update the relevant db file by using
    postmap /etc/postfix/virtual
    ... and any other file with a matching db that you modified

    then you need to reload postfix again of course


    when ever you test and solve above
    check log on server

    tail -f /var/log/mail
    tail -f /var/log/messages
    tail -f /var/log/warn

  3. #3
    Just Joined!
    Join Date
    Apr 2010
    Posts
    2
    hans51, thanks for your reply.

    I've run "newaliases" "postmap /etc/aliases" and everything else I could find via google. There is nothing significant in the logs (/var/log/maillog) other than the not unexpected "connect from unknown" and "disconnect from unknown" which I assume is the cryptic equivalent of "User unknown in local recipient table."

    I was hoping that if I could successfully add a new user I could figure out how to fix a broken, existing user. I thought that by having the local_recipient_map set to "unixasswd.byname $alias_maps" that any linux user would have access to email. If this is supposed to be the case, then something else is broken somewhere.

    BTW, my alias file is in the "key: value" format. When I run postmap /etc/aliases I get a warning (on the console): "warning: /etc/aliases, line x: record is in 'key: value' format; is this an alias file?"

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •