Find the answer to your Linux question:
Results 1 to 2 of 2
Hi, I have proftpd running as a standalone application on my redhat 9 machine. I want to run this via xinetd now though. I altered the proftpd.conf file to say ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Posts
    1

    proftp and xinetd


    Hi, I have proftpd running as a standalone application on my redhat 9 machine. I want to run this via xinetd now though.

    I altered the proftpd.conf file to say inetd instead of standalone for ServerType. That was the only change I made to that file. OK?

    I created a file in /etc/xinetd.d/ called proftpd and I put this stuff in that file:

    service ftp
    {
    disable = no
    socket_type = stream
    wait = no
    user = root
    server = /usr/local/ftpd/sbin/proftpd
    nice = 10
    }

    OK?

    But now when i restart the xinetd server (by typing /etc/init.d/xinetd restart) it says it started but I can't ftp to 127.0.0.1 which I could do perfectly fine when it was running as a standalone application.

    Any help? thanks.

  2. #2
    Linux Engineer jledhead's Avatar
    Join Date
    Oct 2004
    Location
    North Carolina
    Posts
    1,077
    isn't there an /etc/xinetd.conf file that you need to edit, then restart xinetd

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •