Find the answer to your Linux question:
Results 1 to 4 of 4
Hello, I am trying to setup smart monitoring using smartd but it refuses to start. I have installed smartmontools and I am able to run smartctl -i /dev/[device] for all ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! TheMayhem's Avatar
    Join Date
    Apr 2007
    Location
    Sweden
    Posts
    32

    Problem setting up S.M.A.R.T monitoring


    Hello,

    I am trying to setup smart monitoring using smartd but it refuses to start.

    I have installed smartmontools and I am able to run smartctl -i /dev/[device] for all my drives and see that they are smart enabled.

    However, when I try to run service smartd start it fails:
    Code:
    # service smartd start
    Starting smartd (via systemctl):  Job failed. See system logs and 'systemctl status' for details.
                                                                    [FAILED]
    /var/log/messages tell me:
    Code:
    Oct 16 00:02:10 holisrv2 systemd[1]: Failed to load environment files: No such file or directory
    Oct 16 00:02:10 holisrv2 systemd[1]: smartd.service failed to run 'start' task: No such file or directory
    What are these environment files it is looking for?


    I have looked around a bit and I have /etc/smartd.conf with the following content:
    Code:
    # Sample configuration file for smartd.  See man smartd.conf.
    
    DEVICESCAN -S on -o on -a -I 194 -m myname@myserver.com -s (S/../.././02|L/../../6/03)
    I did for some reason not have /etc/defaults/smartmontools. I tried creating it manually but to no effect. It now contains:
    Code:
    # cat /etc/default/smartmontools 
    # Defaults for smartmontools initscript (/etc/init.d/smartmontools)
    # This is a POSIX shell fragment
    
    # List of devices you want to explicitly enable S.M.A.R.T. for
    # Not needed (and not recommended) if the device is monitored by smartd
    #enable_smart="/dev/hda /dev/hdb"
    
    # uncomment to start smartd on system startup
    start_smartd=yes
    
    # uncomment to pass additional options to smartd on startup
    smartd_opts="--interval=1800"
    Looking in /etc/init.d/smartd I find (among others) the following lines:
    Code:
    # Source function library
    . /etc/rc.d/init.d/functions
    
    # Source configuration file
    [ -r /etc/sysconfig/smartd ] && . /etc/sysconfig/smartd
    I have none of the files mentioned.

    I appreciate any help I can get.

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,890
    Thread moved at OP's request.
    Linux user #126863 - see http://linuxcounter.net/

  3. #3
    Just Joined!
    Join Date
    Oct 2011
    Posts
    50
    Since you are running mandrivia I assume you are missing some smartd dependencies, I am not sure which one exactly however. My suggestion is for you to check if all dependencies are installed

  4. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    What distro are you running? Is it really mandriva? On my system, the required config file is:
    Code:
    /etc/sysconfig/smartmontools
    and it contains:
    Code:
    smartd_opts="-q never"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •