Find the answer to your Linux question:
Results 1 to 2 of 2
Hello, I am a Site Systems Support for a building of nearly 700 people. I have used Ubuntu before, but only as a secondary OS, so I am not very ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2011
    Posts
    1

    Grabbing Ubuntu Image Via Integrated NIC


    Hello, I am a Site Systems Support for a building of nearly 700 people. I have used Ubuntu before, but only as a secondary OS, so I am not very knowledgable about it.

    Here is my problem...

    The IT personal that worked here before me had a small PC set up in the server room that worked as a Ubuntu server. We have about 10 computers in the Break Room that employees are allowed to use when on lunch.

    These PCs are set up to automatically boot to Intergrated NIC first, and then pull a Ubuntu image to the Memory. The reason we do this is every time the PC is started up it will load a fresh Ubuntu image, so nobody information is ever saved.

    Yesterday we had some electrical problems, and the PC that was used as the Ubuntu server turned off. The 10 PCs in the break room stayed on, however, 4 of the PCs have been restarted and are failing to grab the Unbuntu image.

    I am a novice with Ubuntu, so if somebody could please walk me through getting the Break Rooms PCs to grab the image again, I would be forever thankful.

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,574
    They are probably using the PXE boot image - a network boot process. They pull the boot image and related files from the server. Is the server running? If the power failure caused the server to do an abnormal shutdown, then you probably need to recover the file system on it before it can be used as a PXE boot server.

    1. Boot the server from a Live/Recovery CD/DVD
    2. Assuming the server has a single file system installed on /dev/sda1, run the command "fsck /dev/sda1".
    3. Reboot the server and try to reboot the client systems.

    If this doesn't work, then you will need to reinstall the PXE boot images on the server. Also, if the server's main file system, or where the boot images are installed are not on /dev/sda1, then you need to execute the command (from the Live/Recovery image) "fdisk -l", and post the output from that here so we can tell you what to do next.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •