Find the answer to your Linux question:
Results 1 to 6 of 6
Hey everyone, I'm a long-time lurker of this site, but I decided to join today because I'm running into an issue I can't seem to figure out. I have a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2011
    Posts
    3

    Apache wont start


    Hey everyone, I'm a long-time lurker of this site, but I decided to join today because I'm running into an issue I can't seem to figure out.

    I have a VPS running CentOS, and I set up a website through it recently. Until yesterday it was working fine, but yesterday I rebooted the machine, and apache wouldn't start. This is what happened:

    Code:
    [***at***/]$ sudo service ht-tpd start
    [sudo] password for ***:
    Starting ht-tpd: (99)Cannot assign requested address: make_sock: could not bind to address 64.30.-224.112: 20
    no listening sockets available, shutting down
    Unable to open logs
                                                               [FAILED]
    [***at***/]$
    I've read some threads where people are having a similar issue, and I followed the steps that fixed it for them (changing ht-tpd.conf to listen on * :-80), but that still doesn't fix it. That part that's confusing me, is that the error pertains to port 20, and an ip address that is not related to my vps at all.

    Nowhere in ht-tpd.conf do I have any mention of that IP address, or port 20.

    Is there some other conf file I need to look at?

    Thanks much,
    Damien

    wont let me use at symbol =/
    sorry for random dash symbols, wouldn't let me post otherwise. It thought I was linking.

  2. #2
    Just Joined!
    Join Date
    Oct 2011
    Posts
    50
    I believe you need to clean all semaphores:
    Code:
    for i in `ipcs -s | awk '/httpd/ {print $2}'`; do (ipcrm -s $i); done
    try starting apache after that

  3. #3
    Just Joined!
    Join Date
    Oct 2011
    Posts
    3
    Quote Originally Posted by vasile002 View Post
    I believe you need to clean all semaphores:
    Code:
    for i in `ipcs -s | awk '/httpd/ {print $2}'`; do (ipcrm -s $i); done
    try starting apache after that
    Thanks for the reply, but unfortunately, after running that, I am still getting the same error.

  4. #4
    Just Joined!
    Join Date
    Oct 2011
    Posts
    3
    Sorry for the double post, just wanted to update with the solution I figured out. I looked through httpd.conf again, and found that it also loads conf files in /etc/httpd/conf.d

    In that directory was ssl.conf, which was trying to listen to port 21 and 20, for reasons I couldn't figure out. I just commented out those lines and its working great now.

  5. #5
    Just Joined!
    Join Date
    Oct 2011
    Posts
    22
    Cat the output of
    Code:
    $ sudo ps -aux| grep httpd
    
    $ kill -9 idprocess

  6. #6
    Just Joined!
    Join Date
    Oct 2011
    Posts
    50
    I wonder how those got there, glad that you were able to fix it

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •