Find the answer to your Linux question:
Results 1 to 6 of 6
Hello Friends i got samba + winbind integrated with my AD 2k3 and i`m able to view AD users using wbinfo -u i`ve setup my samba server to auto-create home ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2011
    Posts
    13

    Question Samba + AD Permission Trouble


    Hello Friends

    i got samba + winbind integrated with my AD 2k3 and i`m able to view AD users using wbinfo -u
    i`ve setup my samba server to auto-create home directories for my AD users when ever they access my linux server

    MY PROBLEM is that when a user try to access his home Directory on the linux box he gets an authentication window, even after entering his Credentials the system dosen`t allow him to access the Directory, although i know its a permission issue , i cant figure out what is missing in my smb.conf file

    i tried to create the user home directory manually and gave it a permission for the AD-User Account, but al in vain !

    i`ve had a look on this wiki but i got lost comparing it to my configuration .


    here is a closer look at my smb.conf ...

    Code:
    # Samba config file created using SWAT
    # from UNKNOWN (0.0.0.0)
    # Date: 2011/10/31 22:27:19
    
    [global]
    	workgroup = MYDOMAIN
    	realm = MYDOMAIN
    	server string = Samba Server Version %v
    	security = ADS
    	log file = /var/log/samba/log.%m
    	max log size = 50
    	idmap uid = 10000-20000
    	idmap gid = 10000-20000
    	cups options = raw
    
    [homes]
    	comment = Home Directories
    	read only = No
    	browseable = yes
            writable = yes
           
    
    [printers]
    	comment = All Printers
    	path = /var/spool/samba
    	printable = Yes
    	browseable = No
    i would be very thankful guys if u can help me with this

    Regards
    Saed ...

  2. #2
    Linux Enthusiast scathefire's Avatar
    Join Date
    Jan 2010
    Location
    Western Kentucky
    Posts
    626
    Try adding
    Code:
    valid users = %S
    to the homes share
    linux user # 503963

  3. #3
    Just Joined!
    Join Date
    May 2011
    Posts
    13
    hi scathefire ,

    tried this before with no luck , the server won`t accept the entered Credentials , any other ideas ?
    thank you ..

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast scathefire's Avatar
    Join Date
    Jan 2010
    Location
    Western Kentucky
    Posts
    626
    When you authenticate, how are you passing the credentials? Are you just typing username? Or MyDomain\username? Or maybe even username@mydomain?
    linux user # 503963

  6. #5
    Just Joined!
    Join Date
    May 2011
    Posts
    13
    my winbind separator is configured to " \ " therefore i`m using the MyDomain\username ,
    i`ve followed a CBT video regarding Samba+Winbind+AD ,
    following all the configuration described in the vedio
    it didn't ask for authentication in the tutorial, it used to access the shared folders automaticly !
    still wondering what could be wrong ?!!
    thanks you scathefire ..

  7. #6
    Linux Enthusiast scathefire's Avatar
    Join Date
    Jan 2010
    Location
    Western Kentucky
    Posts
    626
    What about your logs? Anything in there? If need be, turn up the log level (anything above 10 is quite chatty).
    linux user # 503963

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •