Find the answer to your Linux question:
Results 1 to 3 of 3
Greetings everyone, I am new to Apache2/lampserver, the OS is Suse 11.4 Apache version is 2.xx. I have a moderate knowledge of web creation, mostly on the winders side of ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2010
    Location
    Twin Cities
    Posts
    6

    Question No Access to second drive-(symlink??


    Greetings everyone,

    I am new to Apache2/lampserver, the OS is Suse 11.4 Apache version is 2.xx. I have a moderate knowledge of web creation, mostly on the winders side of things. My first time setting up a web server; I was surprised the initial setup worked perfectly.

    The boot drive has the Suse OS/Lampserver OS about 30 gig in size. It does not have enough room for the web content. The second drive, one terabyte, does.

    The problem: I can access the second drive and files locally just fine. When I try and access from the web, I get the infamous 404 file not found.

    What I have done: changed permissions for all access to secondary drive, the second drive IS mounted via fstab. I've done a fair amount of research on this and still no luck. I am guessing there are settings somewhere that I am not aware of, but without further guidance I'm sorta stuck.

    The drives current mount point is in the media folder, which I know is incorrect. I'm sure it needs to be mounted in Apache, but I have no idea where or how to do that.

    Can someone help to get me unstuck?

    Adriann

    Linux, the Erector Set of Operating Systems

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    The files you are attempting to access via webserver need to either be under your DocumentRoot, or symlinked under your DocumentRoot and FollowSymLinks must be enabled, or you need to configure an alias. In the httpd.conf, you should see examples of these, or just look them up in the Apache manual.

  3. #3
    Linux Enthusiast scathefire's Avatar
    Join Date
    Jan 2010
    Location
    Western Kentucky
    Posts
    626
    you could also look into the --bind option for mount.
    Code:
    mount --bind /source/directory /where/you/want/it
    of course, your system reboots you'll need to add this command to rc.local or something like that.
    linux user # 503963

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •