Find the answer to your Linux question:
Results 1 to 10 of 10
I've been trying to setup my linux box as a Samba PDC for a while. After reinstalling SuSE 9.2 from the DVD (since the web install gave me some funky ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Posts
    15

    Can't log into Samba domain


    I've been trying to setup my linux box as a Samba PDC for a while. After reinstalling SuSE 9.2 from the DVD (since the web install gave me some funky smbpasswd that I couldn't use any command with) I successfully got this Windows XP Pro box to join the domain.

    Great.

    Only problem is, I can't log onto the domain when I boot Windows. I select the domain (called Deus) at the moment, put in my username/password (actually don't have a password), but I can't log on. There must be something I'm missing, but no guide I read really said any step was necessary besides joining the domain.

    I did notice that when I tried to login using root/password it worked. But, trying to set up a home network and all, this is obviously not what I want.

    I'm pretty new to Linux in general so any help would be appreciated. Basically my goal is to have this Windows XP box and three others join the domain. Two of those PCs are to have roaming profiles, but only between each other.

    Thanks in advance.

  2. #2
    Just Joined!
    Join Date
    May 2004
    Location
    Pennsylvania
    Posts
    98
    so you can join the domain, but only after windows starts?

    I'm fairly new with Samba, and never used its domain function, but i just recently set up a share drive that i can use on my network using my routers domain. In order to have everyone on my network access it without a problem i had to create a linux user with the same name as the windows user and the same password (can be blank).

    After that i ran
    Code:
    smbpasswd username
    to create the user as a samba user.

    Not sure if this will work for you, but its something you can try.

  3. #3
    Just Joined!
    Join Date
    Dec 2004
    Posts
    15
    That may be the way to do things, even if a bit sloppy. I'm kind of wondering why, after I joined the domain, the computer shows up in the list of users when I'm logging in.

    Anyway, that solution may work. The only problem then is that I'd assume all the profiles would be roaming profiles; anyone can log in to anyone's computer. This isn't really something I want to be able to happen.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    Don't forget the -a
    smbpasswd -a username

    Mike
    Some people have told me they don't think a fat penguin really embodies the grace of Linux, which just tells me they have never seen a angry penguin charging at them in excess of 100mph. They'd be a lot more careful about what they say if they had.
    -- Linus Torvalds

  6. #5
    Just Joined!
    Join Date
    Dec 2004
    Posts
    15
    I did that and for some reason I can't log in with those usernames, even though it worked a day ago. I get the error message:

    Windows cannot connect to the domain, either because the domain controller is down or otherwise available, or because your computer account was not found.

    I can't even log in as root after I left and re-joined the domain.

  7. #6
    Just Joined!
    Join Date
    Dec 2004
    Posts
    15
    For some reason it's one workstation and one workstation only that I cannot add users on the domain to. This is strange considering that I couldn't do it before or after a format and reinstall of Windows XP.

    When I try to add the user, it gives me the error:

    "The trust relationship between this work station and the primary domain failed."

    What's up with that? The computer has joined the domain successfully and is listed in smbpasswd.

  8. #7
    M@
    M@ is offline
    Just Joined!
    Join Date
    Jan 2005
    Location
    Australia
    Posts
    2

    Solution

    Hey Eleo,

    I've been having the same problem with the Samba network at work; basically seems to relate to Windows XP security settings. The following fixed the problem for me:

    Start->run->MMC
    ->File->add/remove snap-in->Add
    -->Add
    --->Group Policy Object Editor->Add
    ---->(Group Policy Object must be 'Local Computer')->Finish
    --->Close
    -->OK
    ->Local Computer Policy
    ->Computer Configuration
    ->Windows Settings
    ->Security Settings
    ->Local Policies
    ->Security Options
    ->Disable "Domain Member: Digitally encrypt or sign secure channel data (always)"

    Restart, and you should be able to log on with your Samba username and password.

    Cheers, hope this helps,

    M@

  9. #8
    Just Joined!
    Join Date
    Jan 2005
    Location
    WI, USA
    Posts
    1

    Kudos M@!

    Thanks for the tip! You saved me hours and hair!


  10. #9
    M@
    M@ is offline
    Just Joined!
    Join Date
    Jan 2005
    Location
    Australia
    Posts
    2

    No worries!

    Glad to save someone the time it took me to work it out!

    As an aside, I think M$ have changed the default for this setting fairly recently as I've set up a few XP boxes before this one with no problem...

  11. #10
    Just Joined!
    Join Date
    Oct 2006
    Posts
    2

    thanks a lot

    Quote Originally Posted by M@
    Hey Eleo,

    I've been having the same problem with the Samba network at work; basically seems to relate to Windows XP security settings. The following fixed the problem for me:

    Start->run->MMC
    ->File->add/remove snap-in->Add
    -->Add
    --->Group Policy Object Editor->Add
    ---->(Group Policy Object must be 'Local Computer')->Finish
    --->Close
    -->OK
    ->Local Computer Policy
    ->Computer Configuration
    ->Windows Settings
    ->Security Settings
    ->Local Policies
    ->Security Options
    ->Disable "Domain Member: Digitally encrypt or sign secure channel data (always)"

    Restart, and you should be able to log on with your Samba username and password.

    Cheers, hope this helps,

    M@
    hi thanks a lot. This was really headache for me.You did a great work

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •