Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, I have web servers configured with the following: RHEL6, Apache 2.2.15-9, php 5.3.3-3 in chrooted environment. The ulimit values are set to 4096 & MaxClients value is 1500. This ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2009
    Location
    Mumbai, India
    Posts
    95

    Apache stops responding


    Hi,

    I have web servers configured with the following: RHEL6, Apache 2.2.15-9, php 5.3.3-3 in chrooted environment. The ulimit values are set to 4096 & MaxClients value is 1500. This chrooted environment has worked fine in RHEL5 but something perhaps is causing an issue for RHEL6.

    Of late apache stops responding randomly, sometimes when the process count for apache is just as low as 200, sometimes 800 -900. It never reaches the MaxClient value of 1500.

    The command ps shows apache process running, but the webpages are not served. Apache needs to be killed or restarted to have it functional again. Excerpts from the error_log file

    (11)Resource temporarily unavailable: setuid: unable to change to uid: 48

    Child xxxxx returned a Fatal error... Apache is exiting!

    (43)Identifier removed: couldn't grab the accept mutex (multiple lines of same error)

    (22)Invalid argument: couldn't release the accept mutex

    What could be the possible cause of the issue??? Assistance appreciated

    --Syd

  2. #2
    Just Joined!
    Join Date
    Nov 2011
    Location
    New Zealand
    Posts
    79
    Just a wild guess,

    Has the server got enough memory, is Apache using too much of it?

  3. #3
    Just Joined!
    Join Date
    Aug 2009
    Location
    Mumbai, India
    Posts
    95
    Hi,

    Yes the server has adequate RAM. It's provisioned with 64 GB RAM & at the time of issue 58GB was free ( inclusive of cache / buffers value )

    --Syd

  4. #4
    Just Joined!
    Join Date
    Aug 2009
    Location
    Mumbai, India
    Posts
    95

    [SOLVED] - Apache stops responding

    Setting "AcceptMutex flock" in httpd.conf has resolved it for me.

    --Syd
    Last edited by syd05; 02-15-2012 at 10:38 AM. Reason: Typo

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •